Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,065 Members 40,923 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Keep Losing 4G LTE on Straight Talk. Any guesses?

Tip us?
 
kckruse
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Sep 2010
Question [Q] Keep Losing 4G LTE on Straight Talk. Any guesses?

Hey everyone. I recently bought a used HTC Evo 4G LTE and signed up for Straight Talk using the CDMA Bring Your Own Phone activation kit. Everything works great, but I keep losing 4G LTE. I'll get it for a week after calling the Straight Talk peope up. They have me turn the phone off, they do something on their end, I turn my phone back on, and update the profile and bam, 4G LTE. This only lasts for maybe a week until I have to call again to get 4G going again. I am on Viper4G 3.1.7. Could this be why I keep losing 4G? I don't know. Any help on this matter would be so appreciated. Straight Talk customer service can only get me so far. I thank you.

-Kristopher
 
assumption
Old
#2  
Member
Thanks Meter 12
Posts: 75
Join Date: Jan 2011
I would like to know the answer to this too. I'm planning on switching in a month and would like to cover all bases before going in
 
Mr. Fisk
Old
#3  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2014
Can you share what you asked when calling Straight Talk or know what they did on their end? I have the same phone, but lost 4G completely when activating with Straight Talk. All I get is 3G. I've called support twice, and all they tell me is that it's my phone and I need to contact Sprint.

Had 4G when my service with Ting stopped, had 4G when my phone was trying to activate with Straight Talk (no provider), but not after activation.

Any help here regarding what they did on their end would be greatly appreciated.

Thanks.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes