Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] A bit confused!

OP astrovale

12th May 2014, 04:48 PM   |  #1  
astrovale's Avatar
OP Senior Member
Flag Rimini
Thanks Meter: 16
 
192 posts
Join Date:Joined: Aug 2010
More
It says that all questions are allowed, so here we go!
I'd like to say that I've rooted all my phones and have been rooting them since 2008 at least, so I know how to go about rooting, flashing, using recoveries etc.
However, I now have a predicament: I've upgraded my Z (SGP321) to 4.3 (10.4.B.0.569fw) and now I've learned that I cannot use Doomlord exploit anymore. So here comes the question:

Is there any intelligible way to (a) downgrade to a previous fw version that can use Doomlord exploit and thence obtain root and do all the nice thingies we do when we such privilege?
I've read some of the posts, but it is either a very complicated method or it is explained in a very confused/confusing way.

Any help will be appreciated.
Thanks
Luca
The Following User Says Thank You to astrovale For This Useful Post: [ View ]
12th May 2014, 05:51 PM   |  #2  
Senior Member
LYON
Thanks Meter: 55
 
107 posts
Join Date:Joined: Mar 2010
More
Quote:
Originally Posted by astrovale

It says that all questions are allowed, so here we go!
I'd like to say that I've rooted all my phones and have been rooting them since 2008 at least, so I know how to go about rooting, flashing, using recoveries etc.
However, I now have a predicament: I've upgraded my Z (SGP321) to 4.3 (10.4.B.0.569fw) and now I've learned that I cannot use Doomlord exploit anymore. So here comes the question:

Is there any intelligible way to (a) downgrade to a previous fw version that can use Doomlord exploit and thence obtain root and do all the nice thingies we do when we such privilege?
I've read some of the posts, but it is either a very complicated method or it is explained in a very confused/confusing way.

Any help will be appreciated.
Thanks
Luca

all is explained well in reply 4 of this post : http://forum.xda-developers.com/show....php?t=2703774, you just need to find first an older ftf (version 10.1.C.0.370 or older ) of your tabz model to downgrade if you don't have one and use the files provided in this post for upgrading http://forum.xda-developers.com/show....php?t=2645094
Last edited by ibis69; 12th May 2014 at 06:06 PM.
12th May 2014, 06:19 PM   |  #3  
astrovale's Avatar
OP Senior Member
Flag Rimini
Thanks Meter: 16
 
192 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by ibis69

all is explained well in reply 4 of this post : http://forum.xda-developers.com/show....php?t=2703774, you just need to find first an older ftf (version 10.1.C.0.370 or older ) of your tabz model to downgrade if you don't have one and use the files provided in this post for upgrading http://forum.xda-developers.com/show....php?t=2645094

Done! Thanks!
However now I need to install a custom recovery and hence unlock the bootloader. I will follow instructions on the Sony website, but it says that unlocking the bootloader on non-4.3 firmwares will stop camera functionality: will they be re-acquired later on with rom flashing? Or should I upgrade to a 4.3 rooted firmware and then unlock the bootloader?

Luca

PS: Done that also! Now let the fun begin!!
Last edited by astrovale; 12th May 2014 at 07:01 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes