Watch This Now!

TCL s950 cannot receive signal

1 posts
Thanks Meter: 0
By angelosathan, Junior Member on 13th May 2014, 07:56 AM
Post Reply Subscribe to Thread Email Thread
Hello and thank you in advance guys , this forum is wonderful , I just started going deep into the world of android and found my self scratching my head at many occasions. I have great experience on PC's regarding software and hardware , too bad they are of no use when we talk mobile-phones. So , I got a TCL s950 some days ago , it had 4.2.2 android with English and Chinese language only, I decided to root it and flash a new ROM , I used your thread and got everything done-(the learning curve was a bit vertical for me , I nearly bricked the phone )- my phone boots and everything , it can use WIFI download apps and generally work fine .
Now the problem
Even though the phone can detect SIM instertion I cannot receive/make calls , send SMS , nothing. I can see no signal bars on the indicator whatever I do. I reset the phone back to stock ROM but the problem persists. Could it be a hardware failure? Modem issues? ROM issues? I really don't know... I've been working hours and hours on this , now the next step is to take it to a store and have them check it .
I would appreciate if there was a solution , I will wait patiently for anyone that can help. Good day to all.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes