Post Reply

[Q] Please Help: Unable to find play store services

OP anupsabraham

12th May 2014, 10:42 PM   |  #1  
OP Junior Member
Flag Kochi
Thanks Meter: 0
 
27 posts
Join Date:Joined: Mar 2013
More
Hi,
I cannot find Play Store Services among installed apps on my Galaxy Ace. Its already installed in the phone. Other apps doesn't work without Play Store Services. This happened after relinking application files using link2sd. Is there anyway to fix this problem? Please help.
13th May 2014, 08:40 AM   |  #2  
Senior Member
Thanks Meter: 360
 
956 posts
Join Date:Joined: Dec 2013
More
Quote:
Originally Posted by anupsabraham

Hi,
I cannot find Play Store Services among installed apps on my Galaxy Ace. Its already installed in the phone. Other apps doesn't work without Play Store Services. This happened after relinking application files using link2sd. Is there anyway to fix this problem? Please help.

Try reinstalling it again. Do post the result. Hope I Helped
13th May 2014, 11:07 AM   |  #3  
OP Junior Member
Flag Kochi
Thanks Meter: 0
 
27 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by mahithm

Try reinstalling it again. Do post the result. Hope I Helped

I couldn't Install Play Store Services from Play Store. It was showing as "already installed". So I downloaded an apk file of Play Store Services and installed. That didn't work. Then I tried factory resetting. That didn't work too. I was not able to login to my google account. There were 2 google settings icon in the app drawer too. I suppose it happened because I tried to install the apk file.

Then I did format system and reinstalled my OS. Now my phone is working fine.
13th May 2014, 12:05 PM   |  #4  
Senior Member
Thanks Meter: 360
 
956 posts
Join Date:Joined: Dec 2013
More
Quote:
Originally Posted by anupsabraham

I couldn't Install Play Store Services from Play Store. It was showing as "already installed". So I downloaded an apk file of Play Store Services and installed. That didn't work. Then I tried factory resetting. That didn't work too. I was not able to login to my google account. There were 2 google settings icon in the app drawer too. I suppose it happened because I tried to install the apk file.

Then I did format system and reinstalled my OS. Now my phone is working fine.

Good thing the problem is solved and Play Services are working again
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes