Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,408 Members 53,236 Now Online
XDA Developers Android and Mobile Development Forum

ROM installation problems

Tip us?
 
Roshi69
Old
(Last edited by Roshi69; 13th May 2014 at 08:39 PM.)
#1  
Senior Member - OP
Thanks Meter 51
Posts: 459
Join Date: Mar 2010
Default ROM installation problems

I've been flashing ROMs, recoveries etc for years on every android device I've had, from Samsung to nexus, HTC. Everything. This is my first Motorola and I'm having a lot of problems.

Unlocked the boot loader, flashed TWRP but wouldn't backup my stock ROM so put on Pholz recovery and it wouldn't backup either.

Tried to install C-Rom after the usual wipes and just sticks at boot screen. Tried Tweakone ROM I think its called and same problem.

Any ideas? I have the XT1032

I know about restoring to factory but what I'm asking is, is there anything specific I'm doing wrong? I'm quite an experienced flasher. Research is showing me how to recover the phone but what's gonna stop it happening again

Sent from my Nexus 5 using Tapatalk
 
ATRIXXIRTA
Old
#2  
ATRIXXIRTA's Avatar
Senior Member
Thanks Meter 728
Posts: 2,371
Join Date: Mar 2012
Location: The Shangri-La Motel
A lot of users report issues not being able to flash rom's on 4.4.2 kitkat.

A fix is to downgrade to 4.3, then flash roms.

I dont know why. I bought my device upgraded to 4.4.2 already, and i can flash roms with no issues.

Search the forum for the topic and you will find the info you need.
Phones: Motorola Atrix 4G ---> Samsung Galaxy Nexus (temporarily) ---> LG Optimus 3d ---> Samsung Galaxy SII LTE Skyrocket ---> LG Optimus G ---> Sony Xperia ZL ---> Motorola Moto G
My Roms/Ports: CarbonRom/CarbonClash (port): http://forum.xda-developers.com/show....php?t=2181390
Thanks: XDA and all its members. Without you I'd still be an uneducated bumpkin complaining about my shi**y phone.

 
deej_roamer
Old
#3  
deej_roamer's Avatar
Senior Member
Thanks Meter 274
Posts: 304
Join Date: Mar 2014
Quote:
Originally Posted by Roshi69 View Post
I've been flashing ROMs, recoveries etc for years on every android device I've had, from Samsung to nexus, HTC. Everything. This is my first Motorola and I'm having a lot of problems.

Unlocked the boot loader, flashed TWRP but wouldn't backup my stock ROM so put on Pholz recovery and it wouldn't backup either.

Tried to install C-Rom after the usual wipes and just sticks at boot screen. Tried Tweakone ROM I think its called and same problem.

Any ideas? I have the XT1032

I know about restoring to factory but what I'm asking is, is there anything specific I'm doing wrong? I'm quite an experienced flasher. Research is showing me how to recover the phone but what's gonna stop it happening again

Sent from my Nexus 5 using Tapatalk

It wont backup saying what error?
 
Roshi69
Old
#4  
Senior Member - OP
Thanks Meter 51
Posts: 459
Join Date: Mar 2010
Twrp just said 'failed' in red writing after the data backup I think. And philz touch said something along the lines of Not being able to write a file into the \clockworkmod folder.

I bought the device with 4.4.2 on it and followed the guides after reading up about the problems etc but TWRP 2.7.0.0 had a lot of reports that everything was working on it so went ahead with it

Sent from my Nexus 5 using Tapatalk
 
ATRIXXIRTA
Old
#5  
ATRIXXIRTA's Avatar
Senior Member
Thanks Meter 728
Posts: 2,371
Join Date: Mar 2012
Location: The Shangri-La Motel
Ya that's strange because philz works great for me. Do you have a USB otg to try an external backup?

Sent from my XT1032 using Tapatalk
Phones: Motorola Atrix 4G ---> Samsung Galaxy Nexus (temporarily) ---> LG Optimus 3d ---> Samsung Galaxy SII LTE Skyrocket ---> LG Optimus G ---> Sony Xperia ZL ---> Motorola Moto G
My Roms/Ports: CarbonRom/CarbonClash (port): http://forum.xda-developers.com/show....php?t=2181390
Thanks: XDA and all its members. Without you I'd still be an uneducated bumpkin complaining about my shi**y phone.

 
Roshi69
Old
(Last edited by Roshi69; 14th May 2014 at 10:06 AM.)
#6  
Senior Member - OP
Thanks Meter 51
Posts: 459
Join Date: Mar 2010
I got the phone booted again by following a guide and flashing a stock rom.

Installed Philz recovery again and still getting the backup error. it says: E: Error while backing up boot image!

So understandably i am now scared to flash another rom in case i get a boot loop again.

*update* Strangely i flashed TWRP via CWM, rebooted into TWRP 2.7.0.0 and performed a backup successfully.
 
srujan21
Old
(Last edited by srujan21; 14th May 2014 at 10:59 AM.)
#7  
srujan21's Avatar
Member
Thanks Meter 2
Posts: 45
Join Date: Sep 2012
Location: Hyderabad
Quote:
Originally Posted by Roshi69 View Post
I got the phone booted again by following a guide and flashing a stock rom.

Installed Philz recovery again and still getting the backup error. it says: E: Error while backing up boot image!

So understandably i am now scared to flash another rom in case i get a boot loop again.

*update* Strangely i flashed TWRP via CWM, rebooted into TWRP 2.7.0.0 and performed a backup successfully.
Why dont you use Clockwork mod recovery for flashing Rom. I have flashed 10 Roms with that and all are backed up with out any problems. TWRP has no official support for moto g, and instead of all that why don't you try Cyanogenmod ?
 
TheSkweed
Old
#8  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Nov 2012
(sorry if my english is not perfect)

Hello,

I have exactly the same problem with my XT1032.

Bootloader unlocked, CWM (6.0.4.7) successfully installed and backup done with no issues.
But custom roms won't load...
CM11 is stuck at "bootloader unlocked warning screen" and SlimKat is stuck at slimkat logo.

I never had such problems on my Nexus..

Please help me, I don't know what's going on
 
Ghoorg
Old
#9  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: May 2014
Quote:
Originally Posted by TheSkweed View Post
I have exactly the same problem with my XT1032.

Bootloader unlocked, CWM (6.0.4.7) successfully installed and backup done with no issues.
But custom roms won't load...
CM11 is stuck at "bootloader unlocked warning screen" and SlimKat is stuck at slimkat logo.
Same here. It may be possible to downgrade to 4.3 (see here), but would it then be possible to flash a 4.4.2-based custom ROM ? I'm not sure.
 
Roshi69
Old
#10  
Senior Member - OP
Thanks Meter 51
Posts: 459
Join Date: Mar 2010
Heres the steps I took.

*******Before device was stuck at bootloop*******

1. Bought phone (XT1032)
2. unlocked boot loader
3. Rooted
4. Flashed Philz Recovery (wouldn't backup rom)
5. Flashed TWRP and CWM with same issue.
6. Flashed 2 ROMs to try it (TweakyOne + C-Rom, Both wouldn't boot. and tried on all recoveries.

********Steps after being stuck at bootloop*******
1. Followed this amazing guide here (https://www.youtube.com/watch?v=laU6NQ0LxR0)
2. Set up the stock ROM again
3. Flashed TWRP 2.7.0.0 via Fastboot
4. Backup worked successfully
5. installed CM11 and setup successfully
6. installed Lego rom just to assure myself (currently running this ROM)

I know this is no solution at all but just wanted to share my steps to see what maybe fixed my phone. possibly the stock 4.2.2 rom I flashed was the solution. Maybe the original factory ROM that came on the phone was the issue?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


MediaTek Releases Full Kernel Source for First Android One Devices

Those who might have thought that MediaTek wouldnever release working … more

Submitting a Patch to Gerrit – Featuring XplodWild – XDA Developer TV

Not every developer specializes in every area of … more

Learn How to Make a Live Wallpaper all by Yourself

Stillimages can bebeautiful, but some of you prefer to see animations on your screens. … more

Google Play Services Updated to Version 6.1

In addition to Android operating system proper, Google is focusing hard on giving the developers … more