FORUMS

New Xposed for Lollipop 5.0 Update Fixes Major Bugs

Senior Recognized Developer rovo89 has patched Xposed for Lollipop 5.0 to … more

Download Sony’s new AOSP-like concept for Xperia Z3

Over in our forums, Recognized Contributor Jozinek has posted a very … more

OnePlus 2 vs Moto X Style: Which is The Better Flagship?

Two big industry names have announced their newest flagship phones within the … more

Making Your Own Xposed Modules Is Easier Than You Think

Close to the heart of XDA is the Xposed Framework by Rovo89. Most of … more

Flyme Statusbar

6 posts
Thanks Meter: 0
 
By bluq, Junior Member on 2nd May 2014, 10:46 AM
Post Reply Subscribe to Thread Email Thread
is there anyone can help me to make statusbar like Flyme OS

it look like this



i try from this
http://forum.xda-developers.com/xper...-look-t2275715

but always get error when recompile

Quote:


Log For : SystemUI.apk

Log Type : Recompiling

Log Recorded At : Fri 02-05-2014 16:35:34.11

Log Recorded By : Advanced ApkTool v2.0.0 By BDFreak

------------------------------------------------------

..\3-Out\SystemUI.apk\smali\com\android\systemui\status bar\policy\Traffic$1.smali[24,4] Error for input '.parameter': Invalid directive
..\3-Out\SystemUI.apk\smali\com\android\systemui\status bar\policy\Traffic$1.smali[39,4] Error for input '.parameter': Invalid directive
..\3-Out\SystemUI.apk\smali\com\android\systemui\status bar\policy\Traffic$1.smali[40,4] Error for input '.parameter': Invalid directive
..\3-Out\SystemUI.apk\smali\com\android\systemui\status bar\policy\Traffic$1.smali[39,15] mismatched input '"context"' expecting END_METHOD_DIRECTIVE
Exception in thread "main" brut.androlib.AndrolibException: Could not smali file: com/android/systemui/statusbar/policy/Traffic$1.smali
at brut.androlib.src.SmaliBuilder.buildFile(SmaliBuil der.java:72)
at brut.androlib.src.SmaliBuilder.build(SmaliBuilder. java:56)
at brut.androlib.src.SmaliBuilder.build(SmaliBuilder. java:41)
at brut.androlib.Androlib.buildSourcesSmali(Androlib. java:338)
at brut.androlib.Androlib.buildSources(Androlib.java: 299)
at brut.androlib.Androlib.build(Androlib.java:285)
at brut.androlib.Androlib.build(Androlib.java:258)
at brut.apktool.Main.cmdBuild(Main.java:236)
at brut.apktool.Main.main(Main.java:88)

------------------------------------------------------

here is my original systemui.apk http://www.4shared.com/mobile/VLrXLXssba/SystemUI.html

anyone know where`s i miss
 
 
2nd May 2014, 06:32 PM |#2  
cuatzstress's Avatar
Senior Member
Flag Bekasi, West Java
Thanks Meter: 75
 
More
This happen when u r using Apktool Android did u? I guess u should try with APKTOOL Desktop version, apktool android version could not identify "parameter", and only identify "param"....

Sent from my C1905 using XDA Premium 4 mobile app
3rd May 2014, 04:00 PM |#3  
Kevin-0100's Avatar
Senior Member
Flag Vlaardingen
Thanks Meter: 68
 
More
Using apktool 1.5.2 instead of 2.0 should resolve the compile error

Sent from my C1905 using XDA Premium 4 mobile app
4th May 2014, 05:20 PM |#4  
ansebovi's Avatar
Senior Member
Flag Chennai
Thanks Meter: 1,036
 
More
Quote:
Originally Posted by bluq

is there anyone can help me to make statusbar like Flyme OS
here is my original systemui.apk http://www.4shared.com/mobile/VLrXLXssba/SystemUI.html

anyone know where`s i miss

use this advanced apktool,...
http://forum.xda-developers.com/show....php?t=2639400

and u should use 2 files as framework...like below install both using advanced apktool


4th May 2014, 06:41 PM |#5  
Member
Thanks Meter: 24
 
More
These smali files dont work for me also (i get the same errors). So i suggest to use smali files from Znxt Rom for Xperia M. These files work good for me on stock 4.3 XMS.
12th May 2014, 06:06 AM |#6  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ansebovi

use this advanced apktool,...
http://forum.xda-developers.com/show....php?t=2639400

and u should use 2 files as framework...like below install both using advanced apktool


already use advance apktool and install those 2 framework,
i think its wrong with the smali because its from diferent type device

Quote:
Originally Posted by kosmita1993

These smali files dont work for me also (i get the same errors). So i suggest to use smali files from Znxt Rom for Xperia M. These files work good for me on stock 4.3 XMS.

can u share ur systemui and framework with that znxt,
im using stock 4.3 to
13th May 2014, 08:38 PM |#7  
Member
Thanks Meter: 24
 
More
Quote:
Originally Posted by bluq

can u share ur systemui and framework with that znxt,
im using stock 4.3 to

http://forum.xda-developers.com/show....php?t=2733039
Just decompile SystemUI.apk from this ROM and you will get working smali files.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes