TWRP 2.8.3.0 Available for Supported Devices

The TeamWin Recovery Project (or TWRP, for short) has quickly become one of the most popular … more

Easily Generate and Export Material Design Palletes

For many people, it can be pretty difficult to create a palette of complementary colors. … more

Android One Expanding to Bangladesh, Nepal, and Sri Lanka

At Google I/O 2013, Google proudly announced that the Android operating system was … more

Android 5.0.2 Fixes 2012 Nexus 7! Sony’s Making a Google Glass Competitor? – XDA TV

Android 5.0.2 Lollipop is available for the … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

ROM installation problems

OP Roshi69

13th May 2014, 09:33 PM   |  #1  
OP Senior Member
Thanks Meter: 51
 
465 posts
Join Date:Joined: Mar 2010
I've been flashing ROMs, recoveries etc for years on every android device I've had, from Samsung to nexus, HTC. Everything. This is my first Motorola and I'm having a lot of problems.

Unlocked the boot loader, flashed TWRP but wouldn't backup my stock ROM so put on Pholz recovery and it wouldn't backup either.

Tried to install C-Rom after the usual wipes and just sticks at boot screen. Tried Tweakone ROM I think its called and same problem.

Any ideas? I have the XT1032

I know about restoring to factory but what I'm asking is, is there anything specific I'm doing wrong? I'm quite an experienced flasher. Research is showing me how to recover the phone but what's gonna stop it happening again

Sent from my Nexus 5 using Tapatalk
Last edited by Roshi69; 13th May 2014 at 09:39 PM.
13th May 2014, 10:13 PM   |  #2  
ATRIXXIRTA's Avatar
Senior Member
Flag The Shangri-La Motel
Thanks Meter: 760
 
2,406 posts
Join Date:Joined: Mar 2012
More
A lot of users report issues not being able to flash rom's on 4.4.2 kitkat.

A fix is to downgrade to 4.3, then flash roms.

I dont know why. I bought my device upgraded to 4.4.2 already, and i can flash roms with no issues.

Search the forum for the topic and you will find the info you need.
13th May 2014, 10:43 PM   |  #3  
deej_roamer's Avatar
Senior Member
Thanks Meter: 366
 
328 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by Roshi69

I've been flashing ROMs, recoveries etc for years on every android device I've had, from Samsung to nexus, HTC. Everything. This is my first Motorola and I'm having a lot of problems.

Unlocked the boot loader, flashed TWRP but wouldn't backup my stock ROM so put on Pholz recovery and it wouldn't backup either.

Tried to install C-Rom after the usual wipes and just sticks at boot screen. Tried Tweakone ROM I think its called and same problem.

Any ideas? I have the XT1032

I know about restoring to factory but what I'm asking is, is there anything specific I'm doing wrong? I'm quite an experienced flasher. Research is showing me how to recover the phone but what's gonna stop it happening again

Sent from my Nexus 5 using Tapatalk


It wont backup saying what error?
13th May 2014, 11:58 PM   |  #4  
OP Senior Member
Thanks Meter: 51
 
465 posts
Join Date:Joined: Mar 2010
Twrp just said 'failed' in red writing after the data backup I think. And philz touch said something along the lines of Not being able to write a file into the \clockworkmod folder.

I bought the device with 4.4.2 on it and followed the guides after reading up about the problems etc but TWRP 2.7.0.0 had a lot of reports that everything was working on it so went ahead with it

Sent from my Nexus 5 using Tapatalk
14th May 2014, 01:10 AM   |  #5  
ATRIXXIRTA's Avatar
Senior Member
Flag The Shangri-La Motel
Thanks Meter: 760
 
2,406 posts
Join Date:Joined: Mar 2012
More
Ya that's strange because philz works great for me. Do you have a USB otg to try an external backup?

Sent from my XT1032 using Tapatalk
14th May 2014, 09:58 AM   |  #6  
OP Senior Member
Thanks Meter: 51
 
465 posts
Join Date:Joined: Mar 2010
I got the phone booted again by following a guide and flashing a stock rom.

Installed Philz recovery again and still getting the backup error. it says: E: Error while backing up boot image!

So understandably i am now scared to flash another rom in case i get a boot loop again.

*update* Strangely i flashed TWRP via CWM, rebooted into TWRP 2.7.0.0 and performed a backup successfully.
Last edited by Roshi69; 14th May 2014 at 11:06 AM.
14th May 2014, 11:55 AM   |  #7  
srujan21's Avatar
Member
Flag Hyderabad
Thanks Meter: 2
 
48 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by Roshi69

I got the phone booted again by following a guide and flashing a stock rom.

Installed Philz recovery again and still getting the backup error. it says: E: Error while backing up boot image!

So understandably i am now scared to flash another rom in case i get a boot loop again.

*update* Strangely i flashed TWRP via CWM, rebooted into TWRP 2.7.0.0 and performed a backup successfully.

Why dont you use Clockwork mod recovery for flashing Rom. I have flashed 10 Roms with that and all are backed up with out any problems. TWRP has no official support for moto g, and instead of all that why don't you try Cyanogenmod ?
Last edited by srujan21; 14th May 2014 at 11:59 AM.
14th May 2014, 02:31 PM   |  #8  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Nov 2012
(sorry if my english is not perfect)

Hello,

I have exactly the same problem with my XT1032.

Bootloader unlocked, CWM (6.0.4.7) successfully installed and backup done with no issues.
But custom roms won't load...
CM11 is stuck at "bootloader unlocked warning screen" and SlimKat is stuck at slimkat logo.

I never had such problems on my Nexus..

Please help me, I don't know what's going on
14th May 2014, 04:38 PM   |  #9  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by TheSkweed

I have exactly the same problem with my XT1032.

Bootloader unlocked, CWM (6.0.4.7) successfully installed and backup done with no issues.
But custom roms won't load...
CM11 is stuck at "bootloader unlocked warning screen" and SlimKat is stuck at slimkat logo.

Same here. It may be possible to downgrade to 4.3 (see here), but would it then be possible to flash a 4.4.2-based custom ROM ? I'm not sure.
14th May 2014, 05:30 PM   |  #10  
OP Senior Member
Thanks Meter: 51
 
465 posts
Join Date:Joined: Mar 2010
Heres the steps I took.

*******Before device was stuck at bootloop*******

1. Bought phone (XT1032)
2. unlocked boot loader
3. Rooted
4. Flashed Philz Recovery (wouldn't backup rom)
5. Flashed TWRP and CWM with same issue.
6. Flashed 2 ROMs to try it (TweakyOne + C-Rom, Both wouldn't boot. and tried on all recoveries.

********Steps after being stuck at bootloop*******
1. Followed this amazing guide here (https://www.youtube.com/watch?v=laU6NQ0LxR0)
2. Set up the stock ROM again
3. Flashed TWRP 2.7.0.0 via Fastboot
4. Backup worked successfully
5. installed CM11 and setup successfully
6. installed Lego rom just to assure myself (currently running this ROM)

I know this is no solution at all but just wanted to share my steps to see what maybe fixed my phone. possibly the stock 4.2.2 rom I flashed was the solution. Maybe the original factory ROM that came on the phone was the issue?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes