Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,743 Members 43,318 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Issues Uninstalling Apps

Tip us?
 
cdfosburg
Old
#1  
Member - OP
Thanks Meter 1
Posts: 62
Join Date: Nov 2010
Default [Q] Issues Uninstalling Apps

Hello, I have tried to uninstall apps from my rooted M8 and I continue to get failures every time I try.

I have confirmed that it is rooted and that superuser and busy box are installed. I used the Hasoon2000 method to unlock my bootloader and root the device. I went with the TWRP 2.7.0.2 recovery.

What I am doing wrong that I cannot uninstall an system app?

The variant of the device I have is the T-Mobile M8.
 
exad
Old
#2  
exad's Avatar
Senior Member
Thanks Meter 1392
Posts: 3,338
Join Date: Jan 2010
Location: Montreal

 
DONATE TO ME
Use Titanium backup to uninstall it. Or manually delete the APK files in system/app/ or system/priv-app/ depending on where it's located.

I would strongly suggest freezing system apps first (With titanium backup) and/or permanently as to make sure you don't get any whacky behaviour. If you do you can always unfreeze it but it may be harder to restore an app you uninstalled.
My Phone: Telus HTC One M8: 3.16 HBOOT S-OFF

Exad's m8 everything explained thread for teh noobs

 
lampel
Old
#3  
lampel's Avatar
Senior Member
Thanks Meter 69
Posts: 341
Join Date: Aug 2007
Location: Connecticut
Quote:
Originally Posted by cdfosburg View Post
Hello, I have tried to uninstall apps from my rooted M8 and I continue to get failures every time I try.

I have confirmed that it is rooted and that superuser and busy box are installed. I used the Hasoon2000 method to unlock my bootloader and root the device. I went with the TWRP 2.7.0.2 recovery.

What I am doing wrong that I cannot uninstall an system app?

The variant of the device I have is the T-Mobile M8.
Have you enabled system read/write access? Either by flashing a module or a kernel?

Sent from my HTC One_M8 using Tapatalk
Provider: T-Mobile US
Device: HTC One
 
cdfosburg
Old
#4  
Member - OP
Thanks Meter 1
Posts: 62
Join Date: Nov 2010
I think I was able to identify the issue after a bit of researching. I did not have S-OFF. I took those steps and now it is working like a charm. Thank you everyone for all your help.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes