Default Rogers HTC One Brick After Sense 6.0 Update

Hey guys,

Trying to figure out how to unbrick it before just calling the Carrier to sort things out there. Long story short, updated to 6.0 (stock firmware) and was working fine. But once I restarted the phone later in the day, it just got stuck on the boot screen. Really sucked...

Tried factory reset in the bootloader, no luck. Also tried to use the RUU for the latest firmware available currently, but for obvious reasons it doesn't work.

Therefore at the very least if someone could point towards the RUU version 5.11.631.8 Rogers, that would be a good start.

Free to any suggestions too! Used to flash roms and stuff when I had the Xperia X10 and the HTC Incredible so just need a brushing up on this stuff.

Also BTW, the Hboot is 1.57 but its also S-ON (never bothered to unlock it)
Current & Previous Devices:
HTC One 32GB Silver (Rogers) - 4.1.1 - Ordered, Shipping Next Week
Samsung Galaxy SIII Pebble Blue (SGH-I747 AT&T, Unlocked) - 4.1.1
ASUS VivoTab RT 32GB - Windows RT

HTC Incredible S (S710a Unlocked) - 2.3.3 HTC Sense 2.1
Sony Ericsson Xperia X10a Black (Rogers) - 2.3
Blackberry Pearl Flip 8220 Black (Rogers)
Samsung Galaxy Tab 10.1 Wi-Fi - 4.0.4 ICS