Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Help!!! My top panel with the speaker is peeling off!!

OP 0mnom

10th May 2014, 03:28 AM   |  #11  
OP Junior Member
Thanks Meter: 0
 
21 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by Grizraz

My phone has the exact same issue. Does not seem to get worse, but over a span of a year or two I could see that peeling off substantially more. It is held on by simple adhesive, I'm put off by the issue but then again it is an easy fix.

Can you not replace yours either? I'm tempted to fix it, but I dont want to void the warranty if its needed. This is covered under warranty I assume? Since its happening to multiple people it should be anyway! Itll cost me $99 if I wanna replace it since I bought it from Overseas. I could get a free replacement from Amazon but that requires the US address to send it to. Any trustworthy people out there?? haha

Cheers,
11th May 2014, 02:45 AM   |  #12  
Junior Member
Thanks Meter: 2
 
13 posts
Join Date:Joined: May 2009
More
Quote:
Originally Posted by Grizraz

My phone has the exact same issue. Does not seem to get worse, but over a span of a year or two I could see that peeling off substantially more. It is held on by simple adhesive, I'm put off by the issue but then again it is an easy fix.

Grizraz, did you eventually repair it yourself or did you send it in? My friend bought an m8 and has this problem as well. She's going to bring it back to the carrier to see if they can do something for her. Otherwise she might go the warranty route. I'm considering helping with the repair because it seems easy..

Everyone else who repaired it themselves.. Was it easy?

Sent from my HTC One_M8 using XDA Free mobile app
15th May 2014, 12:19 AM   |  #13  
Member
Thanks Meter: 15
 
91 posts
Join Date:Joined: Apr 2011
I took the phone to the local Sprint dealer, a mall kiosk, they never heard of this happening and simply referred me out to some support number. I have not attempted to fix it yet, will post when I do with photos etc. Hopefully if someone else fixes it, they will do the same
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes