TechTalk Compiles All the Android News You Need in One App

If you’re as obsessed with mobile devices as the vast majority of our forum … more

Android App Review: Google Inbox to Improve Your Life – XDA TV

Recently, Google+ exploded with the announcement of Google Inbox, as … more

Damp the LG G3 Thermal Throttling

As our mobile devices grow thinner and more powerfulwith each passing generation, it’s inevitable … more

Google Play Developer Distribution Agreement Due Tomorrow

Every once in a while, Google updates theGoogle PlayDeveloper Distribution … more
Post Reply

[Q] Mobile Network State: Disconnect. Is It Hardware Problem?

OP miogy

15th May 2014, 02:22 PM   |  #1  
OP Member
Flag Alor Star
Thanks Meter: 0
 
60 posts
Join Date:Joined: Sep 2008
More
Operator: U Mobile (Malaysia)
Rom: 2.3.6(4.5.1.41.MB860.ATT.en.US) flash with CWM using fruit cake rom.
Baseband: N_01.77.36P
Kernal Version: 2.6.32.9 a21`146@zch45Inxdroid55 #2
Status: Can make call and receive sms. Apn setting is good. Wifi and bluetooth also work fine. Only mobile data state is the problem.

Problem:

1.I got this Atrix last 3 week. When i put a sim card it cannot detect my data so i install TWEAKKER from Play Store and get the setting for my APN. Everything work fine.

2. After a week i unlock the bootloader, install Nottachtrix, and again using TWEAKKER to set my APN, have fun with lapdock (overclock it using faux kernal to 1.45ghz). Everything still work fine.

3. Last 5 days i start play around with Titanium backup and supercharged v6. I backup and remove system application that i think i dont need it. I end up with mess around with the system but since i already made a backup i just restore it to default and then i start notice i lost my data signal.

4. I reflash fresh nottachtrix rom using CWM but the data still disconnected. I try flashing other rom like ICS rom also same problem. And then i flash official rom using CWM (fruit cake method) and RSD method. Still no luck. But today i play around with HiAPN and i can connect to data again but it seem not stable. But i can receive Phone call and sms without problem.

5. I already check my sim card by put it to other phone and i got no problem with it.

Any suggestion what i need to do to make data work again normally?

Update 18 May 2014:
1. I reflash 2.3.4 rom using RSD. Mobile Network State still disconnect. I will buy a new sim with different operator to test either my phone got problem or is it the sim/operator problem. Old but powerfull phone. I hope i got change to use it as daily phone again.

Update 21 May 2014:
Already test with other operator also no luck. Flashing all the radio that i found also no luck. Guessing the hardware got problem but quit confuse because call and sms still can receive.
Last edited by miogy; 21st May 2014 at 06:39 AM. Reason: Add the tittle
15th May 2014, 04:46 PM   |  #2  
Senior Member
Flag Córdoba
Thanks Meter: 362
 
1,058 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by miogy

Operator: U Mobile (Malaysia)
Rom: 2.3.6(4.5.1.41.MB860.ATT.en.US) flash with CWM using fruit cake rom.
Baseband: N_01.77.36P
Kernal Version: 2.6.32.9 a21`146@zch45Inxdroid55 #2

Problem:

1.I got this Atrix last 3 week. When i put a sim card it cannot detect my data so i install TWEAKKER from Play Store and get the setting for my APN. Everything work fine.

2. After a week i unlock the bootloader, install Nottachtrix, and again using TWEAKKER to set my APN, have fun with lapdock (overclock it using faux kernal to 1.45ghz). Everything still work fine.

3. Last 5 days i start play around with Titanium backup and supercharged v6. I backup and remove system application that i think i dont need it. I end up with mess around with the system but since i already made a backup i just restore it to default and then i start notice i lost my data signal.

4. I reflash fresh nottachtrix rom using CWM but the data still disconnected. I try flashing other rom like ICS rom also same problem. And then i flash official rom using CWM (fruit cake method). Still no luck. But today i play around with HiAPN and i can connect to data again but it seem not stable.

5. I already check my sim card by put it to other phone and i got no problem with it.

Any suggestion what i need to do to make data work again normally?

Not a smart advice, use it as last resource:

Find the radio version your phone have and flash it, or simply flash another radio. Be careful, tough as an incorrect version (not all radios work on every atrix) you may end with a nice hi-tech papeweight
16th May 2014, 02:49 AM   |  #3  
OP Member
Flag Alor Star
Thanks Meter: 0
 
60 posts
Join Date:Joined: Sep 2008
More
Quote:
Originally Posted by andresrivas

Not a smart advice, use it as last resource:

Find the radio version your phone have and flash it, or simply flash another radio. Be careful, tough as an incorrect version (not all radios work on every atrix) you may end with a nice hi-tech papeweight

I already flash:
a) Radio N_01.77.30P
b) Radio N_01.77.36P
c) Radio N_01.77.37P_usa_att_12dec2011
d) Radio N_01.100.00R

I found all the radio in fruit cakes link except for D. Still no luck. Is it a problem with my phone? I can receive call and sms normally. Only data not work and i believe my APN setting is correct.
17th May 2014, 11:01 AM   |  #4  
OP Member
Flag Alor Star
Thanks Meter: 0
 
60 posts
Join Date:Joined: Sep 2008
More
Already call my operator services and they also can't help. Today will try another sim card with different operator that i will borrow from my friend to check either i need to upgrade my sim or not.

Still hope to get any expert help from XDA forum
8th June 2014, 03:57 AM   |  #5  
OP Member
Flag Alor Star
Thanks Meter: 0
 
60 posts
Join Date:Joined: Sep 2008
More
Any expert? I got iPhone and windows phone but nothing can beat this atrix+lapdock.
17th June 2014, 11:54 AM   |  #6  
Junior Member
Thanks Meter: 0
 
20 posts
Join Date:Joined: May 2014
More
Atrix 4g connectivity
Quote:
Originally Posted by miogy

Any expert? I got iPhone and windows phone but nothing can beat this atrix+lapdock.

Quote:
Originally Posted by miogy

Already call my operator services and they also can't help. Today will try another sim card with different operator that i will borrow from my friend to check either i need to upgrade my sim or not.

Still hope to get any expert help from XDA forum

Hallo miogy,
this is a well known issue,
i am experience the same problem with my atrix 4G,
i recently flash the CM9 of CyanogenMod , (android 4.0.4),
before that i had the 2.3.4 (GB) - in this version my atrix had restart himshelf every day.

on the current version (CM9), i experiencig strange things with the Network.
this is not only us that experiencig that - it is a very common and wide .
its called RIL bug (RIL --> Radio Interface Layer),

my phone can work fine 2 or 5 ot 8 hours, and suddenly the data connection disconnected.
i even once had connected to a Mobile Carrier that is not mine.

as much as i understand till now, this RIL bug is caused of a bug in the Kernel, adn the best guys here in the XDA, are trying to solve it.
i am waiting to this solution very much, because this atrix 4g is great phone, and i like the CM9 also.

you can see for example this thread:
http://forum.xda-developers.com/show....php?t=2603032
Last edited by iTaisHi; 17th June 2014 at 12:15 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes