Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,721 Members 51,740 Now Online
XDA Developers Android and Mobile Development Forum

Stuck on Moto logo for any ROM

Tip us?
 
dooger
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 9
Join Date: Feb 2011
Default Stuck on Moto logo for any ROM

No matter what ROM I load, my green-lens Defy gets stuck on the Moto logo and recovery is no longer accessible, requiring a full SBF to restore. I've tried starting with US TMo 2.1 as well as CEE 2.2.2, and after loading the SBF, I root with either SuperOneClick v2.3.1, or Framaroot, then install 2ndInit 2.3, and then disable USB debug. Up to this point, everything works great and CWM is fully accessible on boot. But attempting to load any custom ROM will result in the stuck moto logo and recovery no longer accessible. I've tried all the wipes before and after installing ROMs, including the defy_fullwipe script, and factory reset. Also tried reformatting the SD. Any ideas??? I can't think of what to try next.

This all started when I recently decided to try MS2Ginger5.1, after successfully running CM7.x for years. MS2Ginger refused to install, so I read that TWRP was needed, so I loaded defy_twrp_recovery_2.6.3.0, and retried MS2Ginger5.1. The installation seemed to proceed and complete normally, however, ever since, my Defy gets stuck Moto logo and no recovery access after loading any ROM, including CM7.2.

Thanks for suggestions - this may be the end of the road for my trusty Defy
 
DiegoxG
Old
#2  
Member
Thanks Meter 43
Posts: 93
Join Date: Sep 2013
Location: Bogota
Since when do you need to install twrp 2.3.6.0 in order to install a gingerbread rom? Install the last version of 2ndinit then install msginger, or if you update to twrp 2.3.6.0 flash a kitkat rom

Sent from my MB525 using Tapatalk 2
 
dooger
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 9
Join Date: Feb 2011
Quote:
Originally Posted by DiegoxG View Post
Since when do you need to install twrp 2.3.6.0 in order to install a gingerbread rom? Install the last version of 2ndinit then install msginger, or if you update to twrp 2.3.6.0 flash a kitkat rom

Sent from my MB525 using Tapatalk 2
Right, TWRP is definitely NOT required to install MS2Ginger, it was just a suggestion which worked for somebody else. I did also try installing kitkat from TWRP (Slim 4.4.2.build.4), but same problem, install seemed to complete normally, but after restarting, stuck at the Moto logo and no recovery
 
DiegoxG
Old
#4  
Member
Thanks Meter 43
Posts: 93
Join Date: Sep 2013
Location: Bogota
There's something you're doing wrong, your defy is not messed up, maybe if you follow the kitkat guide im the General Section just to try, you can get your phone working

Sent from my MB525+ using Tapatalk 2
 
dooger
Old
#5  
Junior Member - OP
Thanks Meter 1
Posts: 9
Join Date: Feb 2011
Quote:
Originally Posted by DiegoxG View Post
There's something you're doing wrong, your defy is not messed up, maybe if you follow the kitkat guide im the General Section just to try, you can get your phone working

Sent from my MB525+ using Tapatalk 2
Followed Quarx's KitKat post and Proverbs2's FAQ to a T, for both CM11 and SlimKat, but neither would boot. In both cases, the ROM would install successfully according to TWRP, and the CM11 or Slim recovery screen would load on reboot, but choosing the option to continue booting, the screen just went black and nothing. The good thing, is that upon restart, it was still possible to enter recovery, so I was able to try several ROMs thanks to safewipe, but nothing would boot after installation. Even so, I eventually ended up back at the stuck Moto Logo and had to RSDlite the CEE full SBF. I have flashed a lot of ROMs over the years, so I don't think I'm doing something wrong, but maybe...

Does starting with a full SBF guarantee there's not some kind of issue with the formatting of /system?
 
DiegoxG
Old
(Last edited by DiegoxG; 15th May 2014 at 05:01 AM.)
#6  
Member
Thanks Meter 43
Posts: 93
Join Date: Sep 2013
Location: Bogota
Have you tried with the nordic sbf? It's quite strange because you can run the stock flash without issues.

I know you already followed the guides and everything, but I'm gonna tell you my steps:

1. Flash sbf with rsdlite (in my case it's a bl7 2.3 miui based, already rooted)
2. Flash twrp recovery 2.6.3.0
3. safewipe.zip
4. Flash CM11, boot, then flash gapps.

Maybe your problem could be because of your sbf, here is the nordic sbf, android 2.2.2
http://depositfiles.org/files/dcjx19kb8

That's all I can help you mate

Sent from my MB525 using Tapatalk 2
The Following User Says Thank You to DiegoxG For This Useful Post: [ Click to Expand ]
 
dooger
Old
#7  
Junior Member - OP
Thanks Meter 1
Posts: 9
Join Date: Feb 2011
Default SOLVED!

OMG, I had just about given up, but the microSD card I was using was at fault. The offending card was a Sandisk Ultra, 16GB HC1. I've been using that Sandisk card in an HD camcorder for months without issue, but for whatever reason the card is not compatible with the Defy during the flashing process. I switched to an 8GB Kingston Class 4, and everything's working again. Anyway, thanks for the suggestions; hopefully this thread will help somebody else.

The Following User Says Thank You to dooger For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Play Your Hits and Learn the Lyrics with NextGen Music Player

There are plenty of music players for Android available in Play Store. They … more

Control Your Toast Notifications with SlicedToasts

Toasts are delicious, even in their Android flavor. In Android, toast doesn’t lead … more

Rotation Lets You Take Full Control of Your Device’s Orientation Settings

To be brutally honest, the native options for screen … more

Change the Alarm Icon in the Status Bar with Xposed

It’s hard to find a more hated object than your alarm clock. They wake us up nearly … more