Thread Deleted

[Q] Help. Lenovo S820 won't power on

OP GiannisTP

Prev Previous Post   Next Post Next
15th May 2014, 11:51 PM   |  #1  
OP Member
Agios Nikolaos
Thanks Meter: 5
 
32 posts
Join Date:Joined: Nov 2012
More
Quote:

Greetings there fellow xda members...
Yesterday a friend of mine gave me her Lenovo s820 (MT6589) to change her ROM.
It came rooted so I just downloaded from play store 'Mobileuncle MTK tools' and selected update recovery.
I flashed it and then rebooted. The recovery was in Chinese so I rebooted again and searched for an english copy of cwm.

I found a guide here about how to flash a custom ROM on this device and downloaded 'CWM_v6.0.3.4_S820_ROW' that was provided.
I flashed the .img file using mobileuncle but after I pressed reboot the phone wouldn't turn on. Not a boot loop, just nothing.
After a couple of hours searching and trying different solutions the phone powered on and I have no idea how I did it.

Now sometimes it boots, sometimes it doesn't.
Most of the times it boots it's after running memory test using the 'SP Flash Tool v5.1352.01' but I don't thing they are somehow related.
Also, Flash tool displays the following error in memory test "ERROR: NAND Flash was not detected!"
but I had no luck finding a solution for that either or if it is somehow related with the problem since most of the people facing that error had formatted NAND something I didn't.
Thanks for reading, I hope someone can help me fix it otherwise I'm in some serious trouble

Never Mind... fixed it... I downloaded the official lenovo and everything works now.. thanks for reading...
Last edited by GiannisTP; 16th May 2014 at 12:31 AM. Reason: it's not mtk6589, it's mt6589
Subscribe to Thread

Tags
boot, dead, lenovo, mt6589, s820
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Android Q&A, Help & Troubleshooting by ThreadRank