Sony Xperia Z3 Lollipop Framework Ported to CM12

Android 5.0 for Xperia has a unique look and feel. You don’t have to get a Sony … more

Do You Use Recents as a Task Switcher?

Google introduced a revamped Recents interface with Lollipop in the hopes of making it easier for … more

YU Yureka All-in-One ToolBox (CM12S Only)

This packed toolbox by XDA Senior Member gohel.vishal makes many useful tweaks … more

Sony Xperia Z4 Forum Now Available

Sony’s Xperia line has seen plenty of development on XDA, and now that the Xperia Z4 has been … more
Post Reply Subscribe to Thread Email Thread

[Q] Dead pixels in Galaxy S5

9th April 2014, 04:03 PM |#1  
OP Senior Member
Thanks Meter: 37
 
554 posts
Join Date:Joined: Dec 2011
Has anyone found dead pixels in their S5?

Dead pixels in new units out of the box were too common in S3 and S4, i hope this is no longer the case.
 
 
9th April 2014, 04:47 PM |#2  
leoaudio13's Avatar
Senior Member
Somewhere on Earth
Thanks Meter: 191
 
684 posts
Join Date:Joined: Feb 2010
Donate to Me
Quote:
Originally Posted by 0mega007

Has anyone found dead pixels in their S5?

Dead pixels in new units out of the box were too common in S3 and S4, i hope this is no longer the case.

Not many have the s5 now. Mine has none

Sent from my SM-G900F using Tapatalk
9th April 2014, 08:07 PM |#3  
Senior Member
Thanks Meter: 152
 
1,449 posts
Join Date:Joined: May 2012
More
On s4.? Where did you read that amoled doesn't have dead pixels afaik

Sent from my GT-I9500 using Tapatalk
9th April 2014, 08:35 PM |#4  
OP Senior Member
Thanks Meter: 37
 
554 posts
Join Date:Joined: Dec 2011
i have seen dead pixels on 3 S3 and on 2 S4 out of the 5 or six of each one purchased in my office, new from retail stores, and some online also new, most just had one but one s4 had 2 dead pixels and a red stuck one.
Last edited by 0mega007; 9th April 2014 at 08:45 PM.
16th May 2014, 01:15 AM |#5  
Senior Member
Upstate, NY
Thanks Meter: 13
 
154 posts
Join Date:Joined: Apr 2011
More
yep
Definitely noticing a couple dead pixels near the top left portion of the screen. Three weeks old. Going to att tomorrow to complain.
16th May 2014, 01:24 AM |#6  
Junior Member
Flag Southampton
Thanks Meter: 7
 
23 posts
Join Date:Joined: Apr 2014
More
Mine is fine, didn't even know this was an issue which is surprising considering we have a phones 4u store in our department. I haven't heard any dead pixel issues.
16th May 2014, 05:15 AM |#7  
xda23's Avatar
Senior Member
Thanks Meter: 145
 
1,948 posts
Join Date:Joined: Sep 2013
Mine don't have any either.
16th May 2014, 05:36 AM |#8  
justanotherasian's Avatar
Member
Thanks Meter: 13
 
50 posts
Join Date:Joined: May 2014
i don't see any in mine...
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes