Update Overload: SuperSU Heavily Updated

There are apps and apps out there. Very few can reach the level of popularity required to stay at … more

Lollipop Leak Available for the Sprint Galaxy S5

Since the Android 5.0Lollipop’s official release not too long ago, we’ve seen … more

CPU Spy Gets an Android Lollipop Makeover

At some point in the distant past, you probably heard of CPU Spy for Android by XDARetired … more

Amazon Fire TV Stick vs Chromecast – XDA TV

There is no doubt that Amazon is a huge player in many markets, and they want to be a huge … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Maintaining 4G connection issues?

OP jmchain

13th May 2014, 04:52 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
2 posts
Join Date:Joined: Feb 2010
I just got my m8, and it's completely stock, not even rooted yet. I'm having trouble maintaining a 4G connection. Even when I'm in an area with a strong signal, my phone eventually falls back to 3G and then won't upgrade to 4G until I enter and exit airplane mode again.

Is this common? any ideas on how to fix it before I just bring it back?

Thanks!

[Edit]
I went to the verizon store and got a new SIM card, and that's resolved the issue, I get a good solid 4G connection on a consistent basis. Maybe the old one wasn't maintaining connection? not sure but it's fixed now.

Thanks!
Last edited by jmchain; 15th May 2014 at 01:24 AM. Reason: Problem Solved
The Following User Says Thank You to jmchain For This Useful Post: [ View ]
13th May 2014, 08:04 AM   |  #2  
Senior Member
Thanks Meter: 54
 
250 posts
Join Date:Joined: Feb 2012
That's weird. Maybe you have a defective phone. Go get it exchanged.

Sent from my HTC One M8 using Tapatalk
13th May 2014, 09:04 AM   |  #3  
DroidRootz's Avatar
Member
Thanks Meter: 13
 
54 posts
Join Date:Joined: Feb 2014
More
I just got my M8 too and my 4G seems to be about the same as my last phone
...maybe a little bit better
13th May 2014, 05:25 PM   |  #4  
Senior Member
Thanks Meter: 815
 
2,718 posts
Join Date:Joined: Mar 2010
More
Quote:
Originally Posted by jmchain

I just got my m8, and it's completely stock, not even rooted yet. I'm having trouble maintaining a 4G connection. Even when I'm in an area with a strong signal, my phone eventually falls back to 3G and then won't upgrade to 4G until I enter and exit airplane mode again.

Is this common? any ideas on how to fix it before I just bring it back?

Thanks!

Quote:
Originally Posted by DroidRootz

I just got my M8 too and my 4G seems to be about the same as my last phone
...maybe a little bit better

Have seen this personally on 3 devices (all purchased from different locations). 2 employees and 1 myself. Its like it takes longer to get a 4G signal. I cant figure it out, but have learned to deal with it. It eventually gets a 4G lock, just not as soon as I would like. I have noticed that Insert Coin gets a 4G signal faster than the official vzw based ROMs though. Not sure if placebo though as my only ways of testing is watching the phone to see when it gets a 4G signal, when I know its in a strong 4G zone.
15th May 2014, 01:13 AM   |  #5  
OP Junior Member
Thanks Meter: 1
 
2 posts
Join Date:Joined: Feb 2010
I went and got a new sim card and surprisingly enough that seems to have solved the issue. Maybe there just wasn't a good connection with the old one? Not sure, but problem solved.

Thanks!
16th May 2014, 09:58 PM   |  #6  
DigiDave's Avatar
Senior Member
Flag Los Angeles, CA
Thanks Meter: 18
 
166 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by jmchain

I just got my m8, and it's completely stock, not even rooted yet. I'm having trouble maintaining a 4G connection. Even when I'm in an area with a strong signal, my phone eventually falls back to 3G and then won't upgrade to 4G until I enter and exit airplane mode again.

Is this common? any ideas on how to fix it before I just bring it back?

Thanks!

[Edit]
I went to the verizon store and got a new SIM card, and that's resolved the issue, I get a good solid 4G connection on a consistent basis. Maybe the old one wasn't maintaining connection? not sure but it's fixed now.

Thanks!

I had similar issues when I got mine. I switched from my S4 to the M8 and had to get a new Nano SIM card to fit the M8. It had issues with connecting to any data connection but I was able to fix it by taking out the SIM and then pushing it back in but not too firmly. I suppose it was the positioning of the SIM with the tray.
Post Reply Subscribe to Thread

Tags
4g connectivity, connectivity problem, htc one (m8)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes