Default [REQUEST] [Dual]Port 4.3 framework for 4.2.2

Someone please port 4.3(15.5.A.0.18)
framework and system ui for 4.2.2(15.2.A.2.5)