Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,682 Members 42,289 Now Online
XDA Developers Android and Mobile Development Forum

My Glass Stuck in "GLASS"...and then ,i found some interesting things.

Tip us?
 
waterangle
Old
(Last edited by waterangle; 19th May 2014 at 06:43 AM.) Reason: new issue
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: May 2014
Default My Glass Stuck in "GLASS"...and then ,i found some interesting things.

My Glass Stuck in "GLASS"...and then ,i found some interesting things.

I tried the Hard Reset at the first, but it was useless.

then I tried to flash rom at the fastboot mode. I found something interesting as follows:

when i flashed the rom XE16 to XE17.1, it still stuck in "GLASS"...

i tried the XE11 rom, and it has some different. it passed the "GLASS", but the screen was not work...

wait about 4-5 minutes, i heard the "click" sound, i guessed it's the first screen(teach you how to use the glass), then i tried to complete the teaching and entry the "bluetooth pair" mode, it successfully finished pairing with my phone.

the rest was easy, join a wifi, close the bluetooth on the phone, waiting the glass autoupdate.

about 10 minutes, the glass fully recovered, all modules are working well.

thank god!

to sum, maybe my glass is a special case, but it means some glass can not repair for directly flashing the lastest rom, then it could try to flash the old rom and autoupdate it.

PS:my English is not good, so maybe i could not correctly using some word..

new issue:when i flashed the XE12, my glass was working well. but if i flashed the XE16-XE17.1, it will stuck in a white screen before the logo "GLASS" or "System updating", even it auto updated to XE12.1, it often displayed "system has no response".

does somebody have the same issue? or somebody can help me.
 
ResleyZ
Old
#2  
Junior Member
Thanks Meter 0
Posts: 15
Join Date: Feb 2014
Quote:
Originally Posted by waterangle View Post
My Glass Stuck in "GLASS"...and then ,i found some interesting things.

I tried the Hard Reset at the first, but it was useless.

then I tried to flash rom at the fastboot mode. I found something interesting as follows:

when i flashed the rom XE16 to XE17.1, it still stuck in "GLASS"...

i tried the XE11 rom, and it has some different. it passed the "GLASS", but the screen was not work...

wait about 4-5 minutes, i heard the "click" sound, i guessed it's the first screen(teach you how to use the glass), then i tried to complete the teaching and entry the "bluetooth pair" mode, it successfully finished pairing with my phone.

the rest was easy, join a wifi, close the bluetooth on the phone, waiting the glass autoupdate.

about 10 minutes, the glass fully recovered, all modules are working well.

thank god!

to sum, maybe my glass is a special case, but it means some glass can not repair for directly flashing the lastest rom, then it could try to flash the old rom and autoupdate it.

PS:my English is not good, so maybe i could not correctly using some word..

new issue:when i flashed the XE12, my glass was working well. but if i flashed the XE16-XE17.1, it will stuck in a white screen before the logo "GLASS" or "System updating", even it auto updated to XE12.1, it often displayed "system has no response".

does somebody have the same issue? or somebody can help me.
You can't update glass to XE16 or XE17 with only flashing the rom. These updates also give a kernel upgrade. If you let Glass install XE16 or XE17 itself, it will also update the kernel. When the kernel is updated, it isn't possible to go back to firmwares before XE16.

I suggest to contact Google, since they will probably assist you further with your issue.
 
waterangle
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: May 2014
Quote:
Originally Posted by ResleyZ View Post
You can't update glass to XE16 or XE17 with only flashing the rom. These updates also give a kernel upgrade. If you let Glass install XE16 or XE17 itself, it will also update the kernel. When the kernel is updated, it isn't possible to go back to firmwares before XE16.

I suggest to contact Google, since they will probably assist you further with your issue.
i did not know that...and i flashed it back to XE12...
could it OTA update to XE16?

the worst is i'm in China, and i bought it from 3rd party...so i don't know the information of the buyer...i contacted GOOGLE, they said they can not help, because i'm not the first buyer.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes