FORUMS

Analysis & Opinion

[Q] Broken Huawei Ascend P1?

7 posts
Thanks Meter: 0
 
By erickvogler100, Junior Member on 10th May 2014, 11:08 PM
Post Reply Subscribe to Thread Email Thread
Hi Folks, I have a problem with my Huawei Ascend P1. I tried to change the internal battery but I think while trying that, I might damage the phone. After I did that. I wont start up unless I plug it in, it only boots up to the Huawei Screen, vibrates and the turns off.
The funny part is it even boots up in that way without a battery (always plugged in).

The question is the following, what do you think is the problem here? Something got disconnected? May I have broken the battery flex or maybe the power button flex?

Thank you in advance
 
 
10th May 2014, 11:09 PM |#2  
TheArc's Avatar
Recognized Themer
Flag Auckland City
Thanks Meter: 2,056
 
Donate to Me
More
You probably have something disconnected, take out the battery and examine the area for any small wires and slots. This is usually the case, because the device stills boots when plugged in.

Sent from my Nexus 5 using Tapatalk
12th May 2014, 02:24 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by krishneelg3

You probably have something disconnected, take out the battery and examine the area for any small wires and slots. This is usually the case, because the device stills boots when plugged in.

Sent from my Nexus 5 using Tapatalk

Ok, I'll give it a try
15th May 2014, 07:15 AM |#4  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by krishneelg3

You probably have something disconnected, take out the battery and examine the area for any small wires and slots. This is usually the case, because the device stills boots when plugged in.

Sent from my Nexus 5 using Tapatalk

I checked it and everything seems to be fine. I even tried with another power button flex but it keeps doing the same thing, booting up, and going off
15th May 2014, 09:53 AM |#5  
TheArc's Avatar
Recognized Themer
Flag Auckland City
Thanks Meter: 2,056
 
Donate to Me
More
Have you tried doing a factory reset?

Sent from my Nexus 5 using Tapatalk
15th May 2014, 11:43 PM |#6  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by krishneelg3

Have you tried doing a factory reset?

Sent from my Nexus 5 using Tapatalk

Yes, but the only button that seems to work is volume down. I even changed that flex but the problem is still there

I'm clueless...
16th May 2014, 04:12 PM |#7  
gulabsameer's Avatar
Member
Flag India
Thanks Meter: 40
 
Donate to Me
More
Question [REF]
Quote:
Originally Posted by erickvogler100

Hi Folks, I have a problem with my Huawei Ascend P1. I tried to change the internal battery but I think while trying that, I might damage the phone. After I did that. I wont start up unless I plug it in, it only boots up to the Huawei Screen, vibrates and the turns off.
The funny part is it even boots up in that way without a battery (always plugged in).

The question is the following, what do you think is the problem here? Something got disconnected? May I have broken the battery flex or maybe the power button flex?

Thank you in advance

Did you used this video as reference..!??
16th May 2014, 04:50 PM |#8  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by gulabsameer

Did you used this video as reference..!??

What video?
Post Reply Subscribe to Thread

Tags
ascend-p1

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes