Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,786,517 Members 36,870 Now Online
XDA Developers Android and Mobile Development Forum

[WORKING][USBOTG][STOCK] - Atrix 2 USB OTG Host Mode and USB Accessory acquisition

Tip us?
 
Rebelj12a
Old
#1  
Rebelj12a's Avatar
Member - OP
Thanks Meter 16
Posts: 44
Join Date: Mar 2013
Location: Wausau

 
DONATE TO ME
Info 2 [WORKING][USBOTG][STOCK] - Atrix 2 USB OTG Host Mode and USB Accessory acquisition

04/11/2014 - 01:41AM - Central Time

USB OTG does work on the Motorola Atrix 2.

I post this because there are no defining topics listing all the requirements and caveats of making this work currently as of the date. Just alot of help topics to sift through. I got a little obsessive in my search to make this work so this is pretty much a knowledge dump.

Started from original help threads here on the forums (various many... lots), figured things out from there through conversations with Chainfire. Ultimitely fixed with lots of research and use of his USB Host Diagnostics App.

Requirements:

Quote:

Motorola Atrix 2 Stock 4.0.4 - Rooted [stock kernel as well]
(what drove me insane on this was that in USB HOST Diagnostics App it showed kernel support, and API support up to Device detected)

USB OTG Y cable, usb 2.0 (I was concerned about this in the beginning however mine appears to be usb 2.0, got it off amazon.)
(Through research it concerned me that a usb 3.0 would not work. Have not tested this)

USB Drive, usb 2.0
- Tested with a Sandisk Cruzer Micro 1gb
(I assume others will work although there have been some help topics mentioning problems with certain usb drives)
[NOTE]
Must be formatted fat32 - I have noticed a few threads I researched mentioning exfat is not supported for certain devices
(have not confirmed as of post date if exfat is supported for Atrix 2 Stock)

[NEEDED] For USB Host AutoMount
Usb 2.0 Hub (I have an old one i cut apart originally. Dont remember the make, and I lost the housing for it, but hey it works)

---------------

USB Host Diagnostics App by Chainfire
(v1.3 as of post date)
Get it at Play Store [link]
Instructions (i.e. my exact process)

Quote:

I came from testing a multitude of custom roms. None of them worked. I have a help thread on it here. Unconfirmed if any of them work at all I had no success. If you are wondering the post thread is here.

- Flash to stock ICS 4.0.4 (if you are not already)
- Root the Atrix 2

Not sure if the relevant (but this is the exact process I took)
-Install BMM
-Installed Busybox (1.22.1)

-Installed USB Host Diagnostics App
(get your host cable and usb drive ready)
-Ran the app
(Follow the instructions it will ask you at the end if you wish to attempt to fix the issue)
- Say yes to try to fix it.
- Follow instructions (go for a reboot)
- Open up usb diagnostics app.
- Run again to confirm

Congrats!
This will not make it automount.
- You do not need a separate program to do this.

Grab your USB hub, plug the USB Drive into the hub and plug it in. To my surprise it automounted.

Chainfire had mentioned checking out a certain file when I was trying to find custom roms that would work. The file was there but they did not work. I gather that file was added by his program and made it work on stock ICS 4.0.4.

There are alot of other threads for other devices. Samsung requires shorting the last 2 pins on the USB connection. This is not needed for Motorola, but keep this in mind if you are randomly searching for USB OTG answers.

---------------

Thanks: Chainfire

Couldn't have figured this out without his help. I highly recommend his apps, he definitely has a deep knowledge of the android system.

Hopefully that should clear things up a bit for anyone searching for the Atrix 2 USB OTG help. I'm moving on to hopefully port from ICS USB OTG host features to a custom rom like Cyanogen. Ill update a link if I come up with anything.
------------------------------------------------------------------
(er um, space for rent)
------------------------------------------------------------------
"When in doubt just throw Su around like the cheap floozy she is. What could possibly go wrong?"

The Following 3 Users Say Thank You to Rebelj12a For This Useful Post: [ Click to Expand ]
 
uboat55
Old
(Last edited by uboat55; 22nd May 2014 at 07:47 PM.)
#2  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Jul 2013
Hello, maybe someone can guide me for final results and find solution. My plans was watch Tv on lapdock 500pro, after i find dvb-t reciever for android. the model was ]CSL - mini DVB-T Stick (from amazon)
requriments of device informs that phone needs android 4.0 or high, dual core cpu (neon support) and usb otg
i have atrix2 mb865 with stock 4.0.4 +root and text inside /proc/cpuinfo returns - "Features: swp half thumb fatmult vfp edsp neon vfpv3"
last one what i need must be usb otg support, so after i get device i connect it direct to microusb and run installed Air Dtv app, it returns "Device not found" then i find this topic and install Busybox and USB Host Diagnostics and run app. I rush to make it quickly so when start diagnostics app asks me connect usb device but i have no any usb device and otg cable also. so i just plug charge cable in lapdock`s usb and connect it to phone, app little think then ask me to Fix usb otg support and after ask to reboot system. After reboot i try again connect directly that device but app again returns "Device not found" - then i check topic again and start to build otg cable.
After cable was complete i check it by connecting to external power (wall adaptor) then i have results.I run USB Host Diagnostics, start test connect device by otg cable, and app returns me (see pic)
Also, when i connect device by otg cable now system popup "By which programm you want use device" and give choice to Air Dtv or Idtv Mobile, 2 apps. But Air Dtv returns me "Device initialisation failed, unplug device and connect after few seconds" another app cant find device also. (see pic)
Also i install Usb Device info app, and able to see connected device info, system shows me that stick is connected to phone. (see pic)
Also i able to mount usb stick to phone by otg cable with external power, and can view files in it. Means i suggest that otg cable and otg in system works
My final point was view Tv on lapdock but at this step i cant run it on phone, Air Dtv also returns me "device not found" when i try to connect it to lapdock by microusb female - usb male extension (included in package of Tv stick)
Also that device works on pc, i install windows software and check it. Mean stick works and shows tv channels. can be for sure that device works
Hope for your help and support!
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-05-20-12-38-33.jpg
Views:	66
Size:	58.3 KB
ID:	2753433   Click image for larger version

Name:	Screenshot_2014-05-20-12-39-08.png
Views:	55
Size:	42.0 KB
ID:	2753434   Click image for larger version

Name:	Screenshot_2014-05-20-12-39-30.png
Views:	51
Size:	224.3 KB
ID:	2753435   Click image for larger version

Name:	Screenshot_2014-05-20-12-39-58.png
Views:	46
Size:	40.6 KB
ID:	2753436   Click image for larger version

Name:	Screenshot_2014-05-20-12-40-04.png
Views:	46
Size:	104.4 KB
ID:	2753437  

Click image for larger version

Name:	Screenshot_2014-05-20-12-40-14.png
Views:	39
Size:	108.1 KB
ID:	2753438   Click image for larger version

Name:	Screenshot_2014-05-20-12-40-54.png
Views:	46
Size:	65.5 KB
ID:	2753439   Click image for larger version

Name:	Screenshot_2014-05-20-12-42-30.png
Views:	43
Size:	163.9 KB
ID:	2753440  
 
DaFrenchTaco
Old
#3  
DaFrenchTaco's Avatar
Member
Thanks Meter 2
Posts: 41
Join Date: Jul 2012
That solves my problem sort of, I'm going to try to install NUMA and see what results I get. Ill update my post once I'm done
Tags
accessory, host, stock, usb, usb otg
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes