Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Urgent please Help

OP Root Newb

20th May 2014, 04:03 PM   |  #1  
OP Member
Thanks Meter: 2
 
37 posts
Join Date:Joined: Jun 2013
So i tried to get stock rom back on my htc one m8 which is locked to ee and is a uk phone. I cant seem to get past the bootloader page the white fastboot screen.



Please help me.
20th May 2014, 04:20 PM   |  #2  
nobnut's Avatar
Senior Member
Thanks Meter: 2,539
 
6,577 posts
Join Date:Joined: Feb 2010
You'll need to give a little more information rather than "tried to get stock ROM".

What did you do, what did you flash, are you S-On or S-Off? Have you somehow wiped the /system partition? Do you have a custom recovery installed currently?

Have you even unlocked the bootloader?

EDIT: I have to go now. I'm not sure what situation you're in. I don't normally suggest people use Toolkits and the like, but if you are in difficulties, in the first instance do a search (I doubt if you are the first person to have been in whatever position you are in). If you can't sort yourself out from the results, then have a look at this thread.
Last edited by nobnut; 20th May 2014 at 04:26 PM.
20th May 2014, 04:30 PM   |  #3  
OP Member
Thanks Meter: 2
 
37 posts
Join Date:Joined: Jun 2013
Quote:
Originally Posted by nobnut

You'll need to give a little more information rather than "tried to get stock ROM".

What did you do, what did you flash, are you S-On or S-Off? Have you somehow wiped the /system partition? Do you have a custom recovery installed currently?

Have you even unlocked the bootloader?

S-ON i think the system partion is whiped because i cant do anything other than fastboot the bootloader is locked so i cant get into a custom recovery. I was following a youtube video on how to get back to stock after rooting the the guy had me do a oem command in fastboot.
20th May 2014, 04:37 PM   |  #4  
nobnut's Avatar
Senior Member
Thanks Meter: 2,539
 
6,577 posts
Join Date:Joined: Feb 2010
OK. But I'm not sure that you have actually wiped your /system partition.

Before you do anything, in fastboot mode (the white screen with the mutli coloured writing on it), type the following in a command prompt from the fastboot folder/directory on your PC, then press enter:

Code:
fastboot erase cache
and if that does nothing

Code:
fastboot wipe cache
Then try to reboot by typing

Code:
fastboot reboot
and hit enter.

If that doesn't work, grab the toolkit I linked to and you'll want to

1. Unlock bootloader
2. Flash custom recovery (choose TWRP)
3. Sideload ROM from recovery and follow the relevant instructions in recovery (You'll need to download a ROM to your PC and place it in the relevant directory)
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes