Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,914 Members 50,201 Now Online
XDA Developers Android and Mobile Development Forum

Working MMS on Straight talk

Tip us?
 
oscar786
Old
#1  
oscar786's Avatar
Senior Member - OP
Thanks Meter 12
Posts: 112
Join Date: Feb 2008
Location: Great Lakes
Default Working MMS on Straight talk

You have to have custom ROM for the straight talk MMS to work, but If do not want custom ROM, you have to be rooted, you can modify apn settings in System, and MMS will work. this is what you have to do.

Ist enter apn for straight talk, as given all over the web.

Second you have to have HTC M8 rooted, second get SQ Lite Editor from the app store (you have to buy it), after install open sqlite editor open Files tab/data/data/com.android.providers.telephony/databases/telephony.db and open carriers. Delete all carriers that are listed in them including at&t, but leave only Straight talk you have entered in apn setting earlier. Exit SQLite by going backward using back arrow. Reboot phone and you will having data and working mms on Straight Talk using at&t SIM.

I had used this method on HTC M8 (at&t variant) and LG Flex (at&t variant)
..HELPING OTHERS WILL IMPROVE YOUR KNOWLEDGE..BROADEN YOUR VISION..YOU LOSE NOTHING BUT GAIN MORE..
The Following User Says Thank You to oscar786 For This Useful Post: [ Click to Expand ]
 
gmgough
Old
#2  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: May 2014
Default Straight Talk MMS question

Quote:
Originally Posted by oscar786 View Post
You have to have custom ROM for the straight talk MMS to work, but If do not want custom ROM, you have to be rooted, you can modify apn settings in System, and MMS will work. this is what you have to do.

Ist enter apn for straight talk, as given all over the web.

Second you have to have HTC M8 rooted, second get SQ Lite Editor from the app store (you have to buy it), after install open sqlite editor open Files tab/data/data/com.android.providers.telephony/databases/telephony.db and open carriers. Delete all carriers that are listed in them including at&t, but leave only Straight talk you have entered in apn setting earlier. Exit SQLite by going backward using back arrow. Reboot phone and you will having data and working mms on Straight Talk using at&t SIM.

I had used this method on HTC M8 (at&t variant) and LG Flex (at&t variant)
I still cant get MMS to work. Here is my story. (in every step I try numerous APN setting configurations

1. old phone - Samsung Galaxy Skyrocket (LTE, SMS and MMS all worked). Running stock AT&T OS......I think it was 4.1. I also purchased a mini-SIM card from straight talk for LTE support. I used a sim cutter on this same card and then installed in my new HTC M8.

2. New phone - HTC One M8.......Locked AT&T phone running stock kit kat . LTE and SMS work fine. Still cant get MMS working

3. Rooted the HTC One M8. MMS is still not working

4. Installed SQLite and removed all the entries (except straight talk) from the telephony database. Rebooted phone. Only straight talk shows up under APN Names. Yet still not working for MMS. Tried numerous different settings and still cant get MMS working.

I really dont want to install a custom ROM. I have a rooted AT&T HTC M8 running stock kitkat. Can anyone please help me?????

I also tried calling straight talk for tech support. It was the typical support. He wants me to reboot the phone. The support person mentioned that MMS is not guaranteed in the bring your own phone program.......he was not invested in trying to resolve the problem.
 
xStealth
Old
(Last edited by xStealth; 20th May 2014 at 06:18 AM.)
#3  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Aug 2011
Didn't work with my previous settings, though after I changed the MMSC it worked! My settings are below:

Name - Straight Talk
APN - tfdata
MMSC - http ://mms - tf . net (no spaces, didn't work to post since its a url)
Multimedia Message Proxy - mms3.tracfone.com
MMS Port - 80
MCC - 310
MNC - 410
APN Type - default,supl,mms,hipri,tfdata

Hopefully these settings, the suggested fix, or the combination of both fixes things for others! I'm certain I attempted those MMSC settings before, so this fix must have been the solution I needed!

FYI: I'm on stock rooted 4.4.2!
 
gmgough
Old
#4  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: May 2014
Quote:
Originally Posted by xStealth View Post
Didn't work with my previous settings, though after I changed the MMSC it worked! My settings are below:

Name - Straight Talk
APN - tfdata
MMSC - http ://mms - tf . net (no spaces, didn't work to post since its a url)
Multimedia Message Proxy - mms3.tracfone.com
MMS Port - 80
MCC - 310
MNC - 410
APN Type - default,supl,mms,hipri,tfdata

Hopefully these settings, the suggested fix, or the combination of both fixes things for others! I'm certain I attempted those MMSC settings before, so this fix must have been the solution I needed!

FYI: I'm on stock rooted 4.4.2!
Is your phone an ATT? are you using a straight talk sim? Is it an LTE Sim from straight talk? Or an ATT sim? and is your phone an HTC M8? Are you using the built in messaging? Or some other messaging application? do you have any other apn's defined on the screen?

If we have the same phone and the same setup it really makes no sense as to why one would work and the other would not.
 
xStealth
Old
#5  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Aug 2011
ATT Phone, ST LTE ATT SIM, and yes, it's an HTC One M8
 
shaqqq
Old
#6  
shaqqq's Avatar
Senior Member
Thanks Meter 7
Posts: 444
Join Date: Apr 2011
I'm using my M8 on T-Mobile it's AT&T and I can do everything besides send and receive pictures it sucks.

Sent from my HTC One_M8 using Tapatalk
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...