Post Reply

[Q] Samsung Galaxy S3 SGH-i747M. Screen black but reponds to touch.

OP OERB57

21st May 2014, 03:16 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2014
I was running a rooted Bell S3 (d2can) on PAC ROM, with the dkp kernel. A while back when i turned it on the screen was completely black. Everything was working normally - Touch worked, LED turned on, vibrate when i unlock - but I couldn't see what i was doing. Recovery and Download mode worked perfectly fine.

I did a factory reset, and it was working fine but shortly after it happened again. Determined I had found the source of the problem, i did another wipe, but the very same day when i turned it on, same thing.

Looked around, seemed others were having the same problem, but usually if their phone was dropped. I haven't dropped my phone recently. In those threads it says to get a screen replacement but I want to investigate other options first.

Any ideas?

EDIT:
Removing battery for at least five minutes then turning on phone fixes problem, but after reboot problem returns.
Last edited by OERB57; 21st May 2014 at 02:06 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes