Smile Workaround - How to achieve MHL Lag Free Gaming on Z Ultra

Hi all, just want to share some simple workaround on how to achieve MHL lag free gaming.

(Some of you might have already know how to do this, but this simple info will still benefits other users)

I search the forum & found little information on this topic, hence I decided to write one myself

Our Z Ultra use MHL 1 (Not MHL 2 or 3) & when I first connect it to my TV, the display is being fixed at: 1080/24p

At 24 frames per second, I can watch movies & videos without issue. But I noticed a minor lag when I open apps & the whole phone UI just feels slow....

Things get really worse, when I try to play games via MHL output on my TV (I use dualshock 3 controller + sixaxis app)

The lag is killing me & made most 60FPS games unplayable, I even tried 30FPS games & still notice a minor input lag.

For gaming, basically we need 60FPS output, 24 or 30 FPS is not smooth enough.


With some simple tweaks, we can force the Z Ultra to output 720p at 60FPS (We sacrifice the 1080p display quality in order to achieve a smoother 720p output)

First, you need to access the service menu by dialing *#*#service#*#*

After that, select Service tests, scroll down to TV-Out Test & select it

Now connect your phone to your TV via MHL cable/adapter & make sure that it's properly connected.

select Video format

There are a few options to choose from, for gaming we need 60FPS so we choose 1280x720p@60

After that, disconnect the MHL adapter from your phone & then reconnect it again.

The phone should now output 720p at 60FPS to your TV.

Note: If you restart or shutdown your phone, you will need to access service menu & do this simple workaround again.

This should work with other Xperia models as well, as long as you are able to access the service menu & change those settings.

Hope the above info helps


UPDATE: I notice my MHL adapter (3rd party) stops charging the phone after I change the TV output resolution.

If your adapter is doing the same thing, just disconnect it from your phone.

Plug in your microUSB wall charger & let it charge for around 30 seconds.

After that, connect your MHL adapter again to your phone, the problem should be gone.