Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,814,319 Members 51,306 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Can't boot normally with TWRP

Tip us?
 
Megaiamepic
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: May 2014
Phone [Q] Can't boot normally with TWRP

Hi. I recently rooted my phone Xperia S (LT26i) and unlocked its bootloader. I had installed CWM and TWRP recovery in the phone and I have ADB and Fastboot(Android SDK) in my computer. I had earlier flashed CWM but it wasn't working so I flashed TWRP. I had downloaded a custom ROM and Gapps in the PC and I extracted the zip files and copied them into the phone (this was a mistake). I went into TWRP and did factory reset, erased cache and wiped dalvik cache unknowingly Now I can't flash ROM or Gapps and I cannot boot normally. Earlier, ADB used to recognize the device and now it doesn't. When I turn on the phone, the Sony logo appears and pink light glows. But it doesn't go beyond that. It repeatedly restarts the phone till the splash screen. Now I can't boot the phone normally Please help, guys.

P.S. I saw a post suggesting to enter a code in the Terminal module of TWRP but it's not working.
 
fipsix
Old
(Last edited by fipsix; 14th May 2014 at 02:06 AM.) Reason: edit kernel name
#2  
Junior Member
Thanks Meter 1
Posts: 21
Join Date: Nov 2010
Location: Prague
Quote:
Originally Posted by Megaiamepic View Post
Hi. I recently rooted my phone Xperia S (LT26i) and unlocked its bootloader. I had installed CWM and TWRP recovery in the phone and I have ADB and Fastboot(Android SDK) in my computer. I had earlier flashed CWM but it wasn't working so I flashed TWRP. I had downloaded a custom ROM and Gapps in the PC and I extracted the zip files and copied them into the phone (this was a mistake). I went into TWRP and did factory reset, erased cache and wiped dalvik cache unknowingly Now I can't flash ROM or Gapps and I cannot boot normally. Earlier, ADB used to recognize the device and now it doesn't. When I turn on the phone, the Sony logo appears and pink light glows. But it doesn't go beyond that. It repeatedly restarts the phone till the splash screen. Now I can't boot the phone normally Please help, guys.

P.S. I saw a post suggesting to enter a code in the Terminal module of TWRP but it's not working.
I'v got almost similar problem right now, but beyond that I'v flashed custom kernel to mine.

I hope someone will post here soon

edit: the kernel name is Open SEMC
but I think I can get to fast boot, so changing kernel should not be problem. But how to get some ROM to the phone, when I can't connect it anyhow?
 
Mirhawk
Old
#3  
Mirhawk's Avatar
Senior Member
Thanks Meter 138
Posts: 371
Join Date: Jan 2014
Quote:
Originally Posted by Megaiamepic View Post
Earlier, ADB used to recognize the device and now it doesn't. When I turn on the phone, the Sony logo appears and pink light glows. But it doesn't go beyond that. It repeatedly restarts the phone till the splash screen. Now I can't boot the phone normally Please help, guys.
P.S. I saw a post suggesting to enter a code in the Terminal module of TWRP but it's not working.
What do You menan by now not recognizing in adb? While being in adb? Are You able to boot to twrp?

Quote:
Originally Posted by fipsix View Post
I'v got almost similar problem right now, but beyond that I'v flashed custom kernel to mine.
I hope someone will post here soon
edit: the kernel name is Open SEMC
but I think I can get to fast boot, so changing kernel should not be problem. But how to get some ROM to the phone, when I can't connect it anyhow?
If You both are able to boot into recovery(twrp), I recommend You boot into twrp, connect the phone to pc. Then Let the drivers install. After it, start the adb, use this command to command to check if Your device is connected:

Code:
adb devices
Copy the ROM zip to the folder of adb.
Then push the file to sdcard using:

Code:
adb push finlename.zip /sdcard
where filename.zip is Your ROM.
Pressing the is appreciated!
Kitkat - Carbon ROM - abcdjdj
 
Megaiamepic
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: May 2014
Quote:
Originally Posted by Mirhawk View Post
What do You menan by now not recognizing in adb? While being in adb? Are You able to boot to twrp?



If You both are able to boot into recovery(twrp), I recommend You boot into twrp, connect the phone to pc. Then Let the drivers install. After it, start the adb, use this command to command to check if Your device is connected:

Code:
adb devices
Copy the ROM zip to the folder of adb.
Then push the file to sdcard using:

Code:
adb push finlename.zip /sdcard
where filename.zip is Your ROM.

I tried using the adb command but it says "error device not found"
 
Mirhawk
Old
#5  
Mirhawk's Avatar
Senior Member
Thanks Meter 138
Posts: 371
Join Date: Jan 2014
Quote:
Originally Posted by Megaiamepic View Post
I tried using the adb command but it says "error device not found"
You are using windows, right? Do You see the phone connected in the "Device Manager"? It might but under "Other Devices" by the name "Sony Xperia S"
Pressing the is appreciated!
Kitkat - Carbon ROM - abcdjdj
 
fipsix
Old
#6  
Junior Member
Thanks Meter 1
Posts: 21
Join Date: Nov 2010
Location: Prague
Quote:
Originally Posted by Mirhawk View Post
You are using windows, right? Do You see the phone connected in the "Device Manager"? It might but under "Other Devices" by the name "Sony Xperia S"
That's what I've done in the end. Bud I had problem with drivers for my xperia, it seemed that drivers were wrong or something. So I uninstalled them, downloaded new one and voila
 
Mirhawk
Old
#7  
Mirhawk's Avatar
Senior Member
Thanks Meter 138
Posts: 371
Join Date: Jan 2014
Quote:
Originally Posted by fipsix View Post
That's what I've done in the end. Bud I had problem with drivers for my xperia, it seemed that drivers were wrong or something. So I uninstalled them, downloaded new one and voila
Do post which drivers You installed with a link. It might help the other member.
Pressing the is appreciated!
Kitkat - Carbon ROM - abcdjdj
 
fipsix
Old
#8  
Junior Member
Thanks Meter 1
Posts: 21
Join Date: Nov 2010
Location: Prague
Quote:
Originally Posted by Mirhawk View Post
Do post which drivers You installed with a link. It might help the other member.
Ooh sorry, totally forgot about that. I dont have direct link, but I will upload them somewhere tommorow.
 
fipsix
Old
#9  
Junior Member
Thanks Meter 1
Posts: 21
Join Date: Nov 2010
Location: Prague
Default drivers

I hope those are the right ones, because I donwloaded tons of em

http://ulozto.cz/x4tSiM6N/drivers-fa...is-ribeiro-rar

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA Xposed Tuesday: How to Shut Up Your Phone – XDA Developer TV

So many different applications want to send us notifications that … more

Add Some Power to First Generation Snapdragon CPUs

Some older devices still remain very popular. Phones like theHTC Desire, Sony Ericsson … more

Android M Mentions Spotted in Android Code Review

While we are still waiting for Android L to be officially released, the first mentions of … more

Create a Simple Custom Launcher from Scratch

When you are starting your journey intoany sort of development, it’s never easy at the … more