Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,631 Members 45,394 Now Online
XDA Developers Android and Mobile Development Forum

64gb sdcard causing reboots

Tip us?
 
two_cents
Old
#1  
Senior Member - OP
Thanks Meter 68
Posts: 353
Join Date: Mar 2009
Default 64gb sdcard causing reboots

I have a 64gb ultra card that caused my phone to reboot. It wiped itself of all my needed emergency data (nandroids, Rom install files)
The reboots started randomly after not changing anything for weeks. I did my usual nandroid back up using twrp then rebooted the system. On my way to work the phone rebooted 5 times in a row so I tried to wipe cache and Dalvik to fix it... But it didn't help.
I wiped everything and was going to do a fresh install but my memory card was missing my files (folders were there but data is missing in folders
Luckily I had a old install file for acr that I used for emergency. After fresh install it still was rebooting... I removed the memory card and it has been without issues.

Anyone have any advice to why this would happen? Is it just the phone hates exFAT file system? Or do I have a faulty card...

I'm currently formatting (full format not quick format) the card but I learned my lesson to not back up to external storage

Sent from my Nexus 7 using Tapatalk
Current Devices
Verizon HTC ONE M8 (S-OFF)- VIPER ONE M8- Faux kernel
Nexus 7(2013) 16gb - Clean Rom

Previous Devices
HTC DNA
Nexus 7 (2012)
VZW Galaxy Nexus
HTC Thunderbolt
HTC Incredible OLED
 
chino0131
Old
#2  
chino0131's Avatar
Senior Member
Thanks Meter 66
Posts: 519
Join Date: Feb 2010
Location: Washington, DC
Had a similar issue. Only noticed it when I went to flash a new kernel and my phone would boot up fine, then reboot constantly at right about 1 minute and 30 seconds exactly each time. Not sure if it is the SD card failing or what...

That said, i noticed as well that my nandroids that would usually restore fine would now fail. I ended up deleting my back ups since they weren't working, then backing up all other content to my PC. Formatted SD Card in the phone, and everything seems to be fine now. All other files on my SD Card seemed fine, but im backing up from now on to my internal memory.
 
hgoldner
Old
#3  
hgoldner's Avatar
Senior Member
Thanks Meter 540
Posts: 2,074
Join Date: Jun 2010
Location: Southeastern Pennsylvania
Had similar recurring issues with a Sandisk 128g card. Had formatted FAT32 as well as exFAT and was finding that I'd do a Nandroid, reboot, then the handset would report that the sdcard was unformatted. I'm still not quite sure that I've got things figured out, but I did a complete reformat (long version, not quick) on my Windows 7 PC and then inserted the card into the M8. Rebooted once and the handset still recognized, so rebooted into recovery and did a Nandroid. The recovery recognized the nandroid, and I rebooted to ROM one more time. Everything was fine.

I do keep a backup of my sdcard contents (have had more than one card go south through the years); restored the backup and reinserted the card and looks okay now.

I can't say whether FAT32 is more stable than exFAT because I've had it happen with both formats on this particular card. If you do have recurring issues with the card after complete reformatting, I would suggest a warranty return. (I did that with an older 64g card recently that failed seriously --- the microcontroller was making the card suddenly get red hot.)
Verizon Wireless HTC One M8 - Rooted/S-Off
Firmware/Recovery/ROM: 2.21.605.2, TWRP, Skyfall
Asus Transformer TF300T - Rooted/unlocked
Firmware/Recovery/ROM: 10.6.1.27.5; TWRP; CROMI-X
Nexus 7 FHD (2013) - Rooted/locked - KitKat KTU84P (v4.4.4)
Chromecast - Rooted
Firmware/ROM:: FlashCast; Eureka ROM
Retired devices: HTC Rezound; Nexus 7 (2012); HTC Droid Incredible; Arnova 10 G2
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes