Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,016 Members 49,857 Now Online
XDA Developers Android and Mobile Development Forum

Anyone getting freezing issues?

Tip us?
 
prazvt
Old
#1  
Senior Member - OP
Thanks Meter 20
Posts: 126
Join Date: Aug 2011
Location: SF Bay Area
Default Anyone getting freezing issues?

I'm rooted on the stock ROM (.55) with the doomlord's kernel, busybox pro, and fauxclock installed. I set a few of his recommended options but didnt change the governor or scheduler.

Ever so often, when I go to turn on the screen, the phone is unresponsive and I have to reboot. Not sure what's causing it. I'll turn off some stuff and see if that helps.

Anyone else having any freezing probs?

Sent from my D6503 using XDA Premium 4 mobile app
 
Envious_Data
Old
#2  
Envious_Data's Avatar
Senior Member
Thanks Meter 667
Posts: 1,625
Join Date: Oct 2012
Location: Yaizu
Hmm odd

Have you edited developer settings and if so tell me

And with faux clock what settings are you using?
Devices:
Sony Xperia Z2

Roms:
Envi-Rom Z2/S
 
prazvt
Old
(Last edited by prazvt; 19th May 2014 at 09:05 AM.)
#3  
Senior Member - OP
Thanks Meter 20
Posts: 126
Join Date: Aug 2011
Location: SF Bay Area
I had GPU rendering on but thats all. I turned off Dev Options last night.

In Fauxclock, I only enabled recommended options:

CPU Clock - disabled hotplug
Thermal - enabled intellithermal
GPU Governor - enabled msm-adreno-tz
IO Scheduler - disabled Entropy

Today the phone has behaved though. I do need to check if it stays off when I power off though.

EDIT: Doesn't stay off. Goes into a boot loop.

EDIT 2: Uninstalled Faux and phone shutdown ok. Meanwhile, seeing a 'Error Initializing USB' message on boot up.

Sent from my D6503 using XDA Premium 4 mobile app
 
Mr.Rô
Old
#4  
Mr.Rô's Avatar
Senior Member
Thanks Meter 54
Posts: 371
Join Date: Aug 2008
I kind of had that issue, from romAur thread:

Quote:
Originally Posted by Mr.Rô View Post
Anyone having an issue where when they press the power button to sleep the device won't wake up for about 30secs after? Not sure if it's going from 2 to 2.1 or an xposed module so thought I'd ask

Sent from my D6503 using Tapatalk
As you are using a stock rom we only have the kernel in common so that could be the culprit although as I said mine seems to come back to life within a minute or so

Sent from my D6503 using Tapatalk
 
prazvt
Old
#5  
Senior Member - OP
Thanks Meter 20
Posts: 126
Join Date: Aug 2011
Location: SF Bay Area
Quote:
Originally Posted by Mr.R™ View Post
I kind of had that issue, from romAur thread:



As you are using a stock rom we only have the kernel in common so that could be the culprit although as I said mine seems to come back to life within a minute or so

Sent from my D6503 using Tapatalk
Interesting - I don't think I waited to see if it came back up to this point. If it didn't respond, I'd just reset it. But yah - I'd suspect that something about the custom kernel was causing issues. OR, there are certain options in Faux that were causing problems - for ex. CPU Governor or IO Scheduler choices. It would take some experimenting - and changing only one parameter to really get an accurate fix on the problem.

I'm currently trying to figure out how to create a flashable stock kernel from the firmware sources (that was downloaded from Sony update); so I'll probably flash the stock kernel back once I figure it out.

Otherwise, since last night the phone is behaving OK. Current setup:

- CWM + SU 1.94 (root)
- Doomlord's v5.0 kernel
- Stock .55 ROM (relocked the bootloader, did phone repair, re-un-locked the bootloader)
- No other tweaks
 
Mr.Rô
Old
#6  
Mr.Rô's Avatar
Senior Member
Thanks Meter 54
Posts: 371
Join Date: Aug 2008
Still not sure what is causing this but when I replied to you I forgot I had updated romAur so was on default kernel which was when it would wake up 30 secs later, now on romAur and doom kernel I am getting the same issue where it just won't wake up even when a call is incoming. Might be an issue with. 69, it's actually starting to drive me nuts, bring on the cm/AOSP builds I say haha

Sent from my D6503 using Tapatalk
 
prazvt
Old
#7  
Senior Member - OP
Thanks Meter 20
Posts: 126
Join Date: Aug 2011
Location: SF Bay Area
Quote:
Originally Posted by Mr.R™ View Post
Still not sure what is causing this but when I replied to you I forgot I had updated romAur so was on default kernel which was when it would wake up 30 secs later, now on romAur and doom kernel I am getting the same issue where it just won't wake up even when a call is incoming. Might be an issue with. 69, it's actually starting to drive me nuts, bring on the cm/AOSP builds I say haha

Sent from my D6503 using Tapatalk
Yeah - It's been a challenge to get this phone to behave completely stable; but at this point, it's down to a few random issues:

- the charge LED staying on after using the magnetic charger in my car
- the camera app FC'd a few times in the evening while I was at the gym; clearing the app's data and a reboot seemed to fix it.

Honestly, running the stock .55 firmware with root and the .55 stock kernel has been the least glitchy combination for me. I may try some of these new ROMs and Doomlord's kernel again after the next Z2 software update. It looks like another update will be coming in the next month (hopefully).

I've posted the .55 firmware and the stock kernel (to reflash after rooting) in the General section if you wanna give that a shot.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Port Sony Xperia Themes to CyanogenMod 11 with Ease

In addition the obvious proficiency with graphics, creating agood Android theme … more

Cell Phone SIM Unlock Bill Just Steps Away from President’s Desk

For all those who believe that Cinderella stories don’t actually … more

Get Your Cargo to its Destination in 4×4 Military Operations Reborn

Racing games have evolved quite a bit since the days of Pole … more