Post Reply

[Q]Install older version of apk on to newer installed version or root SH-06E 1.00.08

23rd May 2014, 06:45 AM   |  #1  
OP Senior Member
Thanks Meter: 73
 
120 posts
Join Date:Joined: Feb 2008
Hi there, is there anyone know how to install older version of apk on to newer version of apk already installed, and without rooting and patching system with Lucky Patcher, uninstalling newer version.

This may be a weird question. I'm having the situation that I want to root Sharp SH-06E firmware 1.00.08
http://worldtsunami.blog136.fc2.com/blog-entry-52.html
Firmware newer than 1.00.07 has new root protection. This new root protection involved preventing installation of hacked VpnFaker.apk to data partition. Hacked VpnFaker is required for rooting process. The blog says that root is possible if VpnFaker is already installed (used to root on firmware older than 1.00.08), but VpnFaker in data partition on my phone is removed during firmware update. (I was on 1.00.01, root, then unroot to update firmware)

Sharp has a lot of root protection, even on firmware older than 1.00.08, rooting process use workaround that mounts system image file in data partition on boot instead of directly writing file to system partition.

VpnFaker is indeed VpnDialogs of Android System 4.0.4, while newer version installed in system partition is version 4.2.2-1.00.08.

So, is there a way to sign 4.0.4 VpnFaker to has same signature as 4.2.2 VpnDialogs.

I have attached 2 vpnfakers, root tool v26 is for firmware older than 1.00.08, and root tool for 1.00.08 in Japanese.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes


Top Threads in Android Q&A, Help & Troubleshooting by ThreadRank