Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Flashing problems with m7_ul

OP freshlimes

19th May 2014, 06:48 AM   |  #1  
OP Member
Flag Santa Cruz, CA
Thanks Meter: 13
 
42 posts
Join Date:Joined: Nov 2012
More
Hello, I've been trying to flash CM11 among other ROMs to my m7_ul but I've been having no luck. The m7_ul specific version of CM11 from January still flashes fine, but the unified version won't. Is there something I might have missed? I tried searching around but I couldn't find anything either.
19th May 2014, 09:12 AM   |  #2  
davebugyi's Avatar
Senior Member
Flag Dolinka
Thanks Meter: 394
 
2,335 posts
Join Date:Joined: Mar 2010
Donate to Me
More
What error do you get and what recovery do you use?
19th May 2014, 06:51 PM   |  #3  
OP Member
Flag Santa Cruz, CA
Thanks Meter: 13
 
42 posts
Join Date:Joined: Nov 2012
More
It tells me I have a m7_ul and then status exit 0. I'm running twrp 2.7. No s-off, unlocked bootloader.

EDIT: My bad, that's what it says when I run it on CWM.
On TWRP it says E: Error executing updater binary in zip 'path'

EDIT 5/21: Still getting E: Error in 'path' (Status 0) Installation aborted when using CWM and E: Error executing updater binary in zip 'path'. I achieved s-off but it still didn't change anything for me. This is happening with any ROMs that are CM11 based.

Here's a picture of what I'm getting:
Last edited by freshlimes; 21st May 2014 at 09:12 PM.
23rd May 2014, 07:04 AM   |  #4  
OP Member
Flag Santa Cruz, CA
Thanks Meter: 13
 
42 posts
Join Date:Joined: Nov 2012
More
Shameful self bump (v_v) problem still persists. I can flash the ParanoidAndroid build from April 17 but as soon as I cross past the May threshold I can't flash anything else (haven't tested any more from April to be honest).

Sent from my One using Tapatalk
23rd May 2014, 11:20 AM   |  #5  
nkk71's Avatar
Recognized Contributor
Flag Beirut
Thanks Meter: 3,069
 
6,193 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by freshlimes

Shameful self bump (v_v) problem still persists. I can flash the ParanoidAndroid build from April 17 but as soon as I cross past the May threshold I can't flash anything else (haven't tested any more from April to be honest).

Sent from my One using Tapatalk

Recommend you try TWRP 2.6.3.3 or 2.6.3.4, seems 2.7 series has problems with newer ROMs (at least they do with ARHD 7x.x series ROM).

And make sure to check MD5 on your downloads before flashing anything.
The Following User Says Thank You to nkk71 For This Useful Post: [ View ]
23rd May 2014, 11:27 AM   |  #6  
davebugyi's Avatar
Senior Member
Flag Dolinka
Thanks Meter: 394
 
2,335 posts
Join Date:Joined: Mar 2010
Donate to Me
More
I remember there was a change in CM commits, and a lot of people had issues installing the nightlies after 3rd of May. Try TWRP 2.6.3.4 and see if it works.
The Following User Says Thank You to davebugyi For This Useful Post: [ View ]
23rd May 2014, 05:41 PM   |  #7  
OP Member
Flag Santa Cruz, CA
Thanks Meter: 13
 
42 posts
Join Date:Joined: Nov 2012
More
tried TWRP 2.6.3.3 and no positive results. Here's what came out in the recovery log when flashing.

Code:
I:Loading package: TWRP (/script/ui.xml)
I:Loading package: TWRP (/data/media/0/TWRP/theme/ui.zip)
I:Loading package: TWRP (/res/ui.xml)
I:Loading resources...
I:Loading variables...
I:Loading pages...
I:Loading page main
I:Loading page main2
I:Loading page install
I:Loading page flash_confirm
I:Loading page flash_zip
I:Loading page flash_done
I:Loading page clear_vars
I:Loading page confirm_action
I:Loading page action_page
I:Loading page singleaction_page
I:Loading page action_complete
I:Loading page filecheck
I:Loading page rebootcheck
I:Loading page wipe
I:Loading page advancedwipe
I:Loading page formatdata
I:Loading page formatdata_confirm
I:Loading page backup
I:Loading page backupname1
I:Loading page backupname2
I:Loading page backupencryption
I:Loading page backupencryption2
I:Loading page checkbackuppassword
I:Loading page backup_run
I:Loading page restore
I:Unable to open '/data/media/0/TWRP/BACKUPS/HT359W914498'
I:Loading page restore_read
I:Loading page restore_decrypt
I:Loading page try_restore_decrypt
I:Loading page restore_select
I:Loading page renamebackup
I:Loading page restore_run
I:Loading page selectstorage
I:Loading page mount
I:Loading page usb_mount
I:Loading page usb_umount
I:Loading page reboot
I:Loading page settings
I:Loading page timezone
I:Loading page screen
I:Loading page advanced
I:Loading page partsdcard
I:Loading page htcdumlock
I:Loading page lock
I:Loading page filemanagerlist
I:Loading page filemanageroptions
I:Loading page choosedestinationfolder
I:Loading page filemanagerrenamefile
I:Loading page filemanagerrenamefolder
I:Loading page filemanagerchmod
I:Loading page filemanagerconfirm
I:Loading page filemanageracction
I:Loading page decrypt
I:Loading page trydecrypt
I:Loading page terminalfolder
I:Loading page terminalcommand
I:Loading page sideload
I:Loading page installsu
I:Set page: 'clear_vars'
I:Set page: 'main2'
I:Switching packages (TWRP)
SELinux contexts loaded from /file_contexts
E:Cannot load volume /misc!
E:Cannot load volume /misc!
Startup Commands: ro.qc.sdk.audio.fluencetype=fluence
ro.sf.lcd_density=480
ro.com.android.dateformat=MM-dd-yyyy
ro.com.android.dataroaming=true
ro.nfc.port=I2C
ro.boot.dq=PASS
ro.boot.lb=1
ro.boot.cid=CWS__001
ro.boot.mid=PN0712000
ro.boot.emmc=true
ro.boot.mode=recovery
ro.boot.hasfp=0
ro.boot.ddrmid=(0x3)
ro.boot.nledhw=0
ro.boot.carrier=ATT
ro.boot.keycaps=qwerty
ro.boot.baseband=4T.24.3218.09
ro.boot.hardware=qcom
ro.boot.pagesize=2048
ro.boot.serialno=HT359W914498
ro.boot.devicerev=3
ro.boot.bootloader=1.56.5555
ro.boot.efuse_info=4FSL
ro.boot.batt_poweron=good_battery
ro.hwui.path_cache_size=24
ro.hwui.layer_cache_size=32
ro.hwui.texture_cache_size=48
ro.hwui.gradient_cache_size=1
ro.hwui.r_buffer_cache_size=4
ro.hwui.drop_shadow_cache_size=5
ro.hwui.text_large_cache_width=2048
ro.hwui.text_small_cache_width=1024
ro.hwui.text_large_cache_height=1024
ro.hwui.text_small_cache_height=1024
ro.hwui.texture_cache_flushrate=0.5
ro.omni.version=4.4-20131110-m7-HOMEMADE
ro.wifi.channels=
ro.allow.mock.location=1
ro.board.platform=msm8960
ro.build.id=KRT16M
ro.build.date=Sun Nov 10 13:21:41 UTC 2013
ro.build.date.utc=1384089701
ro.build.host=ded1.ktechnology.net
ro.build.tags=test-keys
ro.build.type=eng
ro.build.user=dees_troy
ro.build.display.id=omni_m7-eng 4.4 KRT16M eng.dees_troy.20131110.132122 test-keys
ro.build.product=m7
ro.build.version.sdk=19
ro.build.version.release=4.4
ro.build.version.codename=REL
ro.build.version.incremental=eng.dees_troy.20131110.132122
ro.build.description=omni_m7-eng 4.4 KRT16M eng.dees_troy.20131110.132122 test-keys
ro.build.fingerprint=htc/omni_m7/m7:4.4/KRT16M/eng.dees_troy.20131110.132122:eng/test-keys
ro.build.characteristics=nosdcard
ro.config.ringtone=Ring_Synth_04.ogg
ro.config.alarm_alert=Alarm_Classic.ogg
ro.config.notification_sound=pixiedust.ogg
ro.kernel.android.checkjni=1
ro.secure=0
ro.vendor.extension_library=/system/lib/libqc-opt.so
ro.carrier=unknown
ro.product.cpu.abi=armeabi-v7a
ro.product.cpu.abi2=armeabi
ro.product.name=omni_m7
ro.product.board=m7
ro.product.brand=htc
ro.product.model=One
ro.product.device=m7
ro.product.locale.region=US
ro.product.locale.language=en
ro.product.manufacturer=htc
ro.baseband=4T.24.3218.09
ro.baseband.arch=mdm
ro.bootmode=recovery
ro.hardware=qcom
ro.opengles.version=196608
ro.revision=3
ro.serialno=HT359W914498
ro.9kramdump=0
ro.telephony.call_ring.delay=3000
ro.telephony.call_ring.multiple=false
ro.telephony.default_network=9
ro.bootloader=1.56.5555
ro.debuggable=1
ro.modversion=OmniROM-4.4-20131110-m7-HOMEMADE
ro.factorytest=0
ro.use_data_netmgrd=true
com.qc.hardware=true
dev.pm.dyn_samplingrate=1
lpa.decode=true
net.bt.name=Android
net.change=net.bt.name
init.svc.adbd=running
init.svc.ueventd=running
init.svc.recovery=running
init.svc.choice_fn=stopped
rild.libargs=-d /dev/smd0
rild.libpath=/system/lib/libril-qc-qmi-1.so
wifi.interface=wlan0
debug.sf.hw=1
debug.egl.hw=1
debug.nfc.se=true
debug.nfc.fw_download=true
debug.nfc.fw_boot_download=false
debug.mdpcomp.logs=0
debug.composition.type=dyn
dalvik.vm.heapsize=512m
dalvik.vm.heapmaxfree=8m
dalvik.vm.heapminfree=2m
dalvik.vm.heapstartsize=16m
dalvik.vm.heapgrowthlimit=192m
dalvik.vm.stack-trace-file=/data/anr/traces.txt
dalvik.vm.heaptargetutilization=0.75
persist.gps.qmienabled=true
persist.hwc.mdpcomp.enable=true
persist.sys.usb.config=mtp,adb,adb
persist.sys.dalvik.vm.lib=libdvm.so
persist.audio.vr.enable=false
persist.audio.fluence.mode=endfire
persist.audio.handset.mic=digital
persist.audio.speaker.location=high
persist.timed.enable=true
persist.thermal.monitor=true
keyguard.no_require_sim=true
telephony.lteOnGsmDevice=1

I:Copying file /cache/recovery/log to /cache/recovery/last_log
I:Attempt to load settings from settings file...
I:Loading settings from '/data/media/0/TWRP/.twrps'.
I:Backup folder set to '/data/media/0/TWRP/BACKUPS/HT359W914498'
I:Copying file /etc/recovery.fstab to /cache/recovery/recovery.fstab
I:Version number saved to '/cache/recovery/.version'
I:Mount: Unable to find partition for path '/external_sd'
__bionic_open_tzdata: couldn't find any tzdata when looking for CST6CDT!
__bionic_open_tzdata: couldn't find any tzdata when looking for posixrules!
I:Switching packages (TWRP)
I:Set page: 'install'
I:Set page: 'flash_confirm'
I:Set page: 'flash_zip'
I:Set page: 'flash_zip'
Installing '/sdcard/paranoidota/pa_m7-4.3-BETA3-20140508.zip'...
Checking for MD5 file...
I:Cannot find file /sdcard/paranoidota/pa_m7-4.3-BETA3-20140508.zip.md5
Skipping MD5 check: no MD5 file found.
I:Zip contains SELinux file_contexts file in its root. Extracting to /file_contexts
mount: failed to mount /dev/block/platform/msm_sdcc.1/by-name/system at /system: No such file or directory
about to run program [/tmp/backuptool.sh] with 2 args
cp: can't stat '/system/addon.d/*': No such file or directory
chmod: /tmp/addon.d/*.sh: No such file or directory
unmount of /system failed; no such volume
error: make_ext4fs: open: No such file or directory
longjmp botch.
E:Error executing updater binary in zip '/sdcard/paranoidota/pa_m7-4.3-BETA3-20140508.zip'
Error flashing zip '/sdcard/paranoidota/pa_m7-4.3-BETA3-20140508.zip'
Updating partition details
23rd May 2014, 05:56 PM   |  #8  
davebugyi's Avatar
Senior Member
Flag Dolinka
Thanks Meter: 394
 
2,335 posts
Join Date:Joined: Mar 2010
Donate to Me
More
I read in a CM11 thread, that first you need to flash a CM kernel and then a ROM. Sounds weird, but might worth a try.
The Following User Says Thank You to davebugyi For This Useful Post: [ View ]
23rd May 2014, 06:16 PM   |  #9  
OP Member
Flag Santa Cruz, CA
Thanks Meter: 13
 
42 posts
Join Date:Joined: Nov 2012
More
Thumbs up
Well, after doing some more digging and realizing it was right in front my face, I found this:

http://wiki.cyanogenmod.org/w/HTC_fstab_updates

I was able to flash ROMs after 5/3 without a problem. There was an unofficial recovery that had the fstab update, but thank you for your time and help!
23rd May 2014, 06:27 PM   |  #10  
Senior Member
Thanks Meter: 434
 
1,788 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by freshlimes

Well, after doing some more digging and realizing it was right in front my face, I found this:

http://wiki.cyanogenmod.org/w/HTC_fstab_updates

I was able to flash ROMs after 5/3 without a problem. There was an unofficial recovery that had the fstab update, but thank you for your time and help!

Thanks for posting back! I didnt know of this

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes