Post Reply

[Q] Problem with Network Extender

OP shawngmc

18th February 2014, 10:42 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2010
I'm running into some nasty issues with dropped calls while on a network extender and would love some guidance.

First off, a few config notes:
  • Battery: I'm currently using a ZeroLemon extended battery with the included TPU case. I know it typically does cause a MINOR signal performance drop, but nowhere near what I'm seeing now.
  • ROM: This seems to occur with most ROMs. At a minimum, I've seen this on: CM 10.2.1 final, CM 11 Snapshot M3, Gummy 4.4 nightlies, Mastamoon's CM11 nightlies and the KitKang series.
  • Modem: Currently on VRBMF1
  • Network Extender: I have the 3G Model, SCS-2U01
  • Settings: It doesn't seem to matter if location and bluetooth are enabled or not. NFC is disabled.
  • Apps: I currently check signal via SignalCheck Lite.

When I'm about 3 feet from the network extender, I end up with very poor LTE signal - typically between 100 and 110 dB. When I switch down to CDMA/EVDO only, I get better signal - often 2-3 bars, and IIRC 70-80 dB - but still end up dropping calls way too often.

An example test point from 1am (so should be very low traffic and interference):
LTE -109dBM (LTE/CDMA mode, shows as 'one bar')
CDMA -56dBM (CDMA/EVDO only mode, shows as 'three bars')
1xRTT -85dBM (Connected during both CDMA and CDMA/LTE)

I suspect that I'm running into two issues:
I may be having issues with my network extender - inferference from a nearby PC (wifi is set up in a nearby room, so it's likely not the issue), too close to extender, etc. I know that two other Verizon Samsung Galaxy devices in the apartment work just fine.
The phone can't decide properly between a 'OK' network extender CDMA signal and a 'BAD' LTE signal, and when it prefers an LTE tower, the voice signal suffers for it (I know it's not VoLTE, so I'm not 100% sure what the situation here is.)

My ideal solutions would be, in order:
  1. Everything just works - I don't have to switch LTE on/off, etc. - and I have no dropped calls, ideally talking to the network extender
  2. Some way to swap it automatically - none of the CM hooks seem to exist right now in those builds, so instead of Tasker, etc., right now I have to do it manually. I know of at least one app (Advanced Signal Status) that can manually swap it, so there is an API of some sort...
  3. A fairly easy way to set up wifi-based calling that works with my cell phone number - I've got a Linux server running, so I'm willing to experiment there.

I'd really like to stay on a 4.4 build if possible.

I'll update this main post with more info as I gather it.
Last edited by shawngmc; 19th February 2014 at 11:33 PM.
23rd May 2014, 01:08 PM   |  #2  
Senior Member
Flag Birmingham
Thanks Meter: 14
 
107 posts
Join Date:Joined: Jul 2010
More
I am having this same issue. I have tried CM 11 nightlies, Slim Kat, Carbon Rom; all Android 4.4. I'm going to flash CM 10.2 and see if it is a KitKat issue or a problem with my phone. This is very irritating as my house is a bomb shelter and I get no signal without the network extender.

--
Mooney
23rd May 2014, 05:55 PM   |  #3  
lieffring's Avatar
Member
Thanks Meter: 9
 
93 posts
Join Date:Joined: Oct 2008
I think it's all because of 4g since the network extender is 3g only I have the same problem since I got 4g by my house

Sent from my SCH-I535 using xda premium
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Verizon Galaxy S III Q&A, Help & Troubleshooting by ThreadRank