Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,156 Members 40,456 Now Online
XDA Developers Android and Mobile Development Forum

[Q] How to disable Auto-Orientation-ON on magnetic charging cable

Tip us?
 
Wurstwarenfachverkäuferin
Old
#1  
Member - OP
Thanks Meter 7
Posts: 69
Join Date: Dec 2011
Default [Q] How to disable Auto-Orientation-ON on magnetic charging cable

Sorry if that has already been answered but I didn't find an answer.

When I connect a magnetic charging cable to my z1c, the phone ignores the orientation setting and always auto-rotates the screen. Is there a way to disable that and have the phone strictly stick to the settings (in my case, fixed portrait mode most of the time)?

Thanks for your time. Best regards.
 
einfachgaer
Old
#2  
einfachgaer's Avatar
Senior Member
Thanks Meter 33
Posts: 107
Join Date: Apr 2013
If you are rooted, use the xposed module Disable Desk Dock.
The Following User Says Thank You to einfachgaer For This Useful Post: [ Click to Expand ]
 
emilic
Old
#3  
Member
Thanks Meter 5
Posts: 54
Join Date: Mar 2007
Check ur smart connect settings maybe it is changing orientation when it detects ur magnetic charger.

Sent from my D5503 using Tapatalk
 
Wurstwarenfachverkäuferin
Old
#4  
Member - OP
Thanks Meter 7
Posts: 69
Join Date: Dec 2011
Thx for the suggestions. I might try to install Xposed in the nearer future, I guess. In Smart Connect, there no active events.

Can anybody confirm my device acts the same as all do (or not)?
On connecting the magnetic charger, the screen will auto-rotate depending on the orientation of the phone, even with orientation fixed in settings.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes