Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

kindle fire 1st gen location does not work with new play service

OP miro101

18th April 2014, 03:10 PM   |  #1  
OP Member
Thanks Meter: 5
 
45 posts
Join Date:Joined: Jan 2012
Hi,
im using the fire with wifi location with google play service 4.0.... this work.

but there is a new version 4.3... maps promots to install this update. eventually this gets autoupdated and location stops working.

after reflashing to the same rom with old gapps that inculdes the google play service 4.0... the wifi location works until the autoupdated moves it to 4.3.

how to fix this?

or disable the autoupdate (even if playstore auto update is disabled after sometime its upgraded)
The Following 2 Users Say Thank You to miro101 For This Useful Post: [ View ]
12th May 2014, 12:18 AM   |  #2  
OP Member
Thanks Meter: 5
 
45 posts
Join Date:Joined: Jan 2012
any news here?

4.0 and 4.2 of "google play service" has wifi location, and 4.3 und 4.4 of "google play service" has no wifi location
Last edited by miro101; 12th May 2014 at 03:56 PM.
The Following User Says Thank You to miro101 For This Useful Post: [ View ]
12th May 2014, 01:51 PM   |  #3  
Member
Thanks Meter: 23
 
50 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by miro101

any news here?

4.0 and 4.2 of gapps has wifi location, and 4.3 und 4.4 of gapps has no wifi location

I didn't know this worked in previous versions.

I wonder if getSystemAvailableFeatures() returns android.hardware.location.gps on otter ROMs.

EDIT: Found this: https://play.google.com/store/apps/d....checkfeatures
I'll try it when I get home.
Last edited by Idontwantausername; 12th May 2014 at 01:54 PM.
12th May 2014, 03:59 PM   |  #4  
OP Member
Thanks Meter: 5
 
45 posts
Join Date:Joined: Jan 2012
thats a nice idea!

in my previous post i misused the term gapps. i meant "google play service"

so again:
4.0 and 4.2 of "google play service" has location working with wifi, and 4.3 und 4.4 of "google play service" has no wifi location.

example google maps:
with 4.0 and 4.2 of "google play service" there is the blue dot for location on the map and you can see a symbol on the notification bar.

with 4.3 and 4.4 of "google play service" there is NO blue dot on the map. after clicking on the location button a message shows "searching for location" but nothing follows. In the notification bar there is SOMETIMES the symbol for location. but a location never shows up.

whats interesting with 4.3+ in the "google play service" location settings googlemaps in shows as the last app to request location. it seems as the get location works but the return handle from system to app is broken
Last edited by miro101; 12th May 2014 at 04:09 PM.
24th May 2014, 01:59 AM   |  #5  
lovejoy777's Avatar
Senior Member
Flag Nottingham
Thanks Meter: 2,894
 
3,138 posts
Join Date:Joined: Dec 2011
Donate to Me
More
what rom guy's? I thought it was just my slimkat build with this problem, Ive been looking for a fix myself (but to no avail ) nice you have pinpointed where it goes wrong.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes