Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Verizon S4 "camera failed" since KitKat update

OP dconn

24th May 2014, 05:48 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Sep 2011
I'm having bizarre camera issues since the KitKat update and I think it might be similar to the issues on the S5. My front camera will work after a reboot, as I'm able to take pictures of checks with my bank app that doesn't access the front facing camera. However, when I use the camera app (stock or Google) or Snapchat, the camera goes black. I then get the "camera failed" message.

I tried force stopping the camera and clearing data and cache. I also tried to factory reset and still had no luck. I went into Verizon and they told me they could only give me a refurb, not a brand new phone. I've had issues with refurbs back when I had a gnex so I want to avoid that I route.

One other thing - I do think I was rooted when I updated to KitKat. Could that have anything to do with it? I vaguely remember rooting right when I got the phone, but when I found out I couldn't unlock the bootloader I never did anything further with it.

I read about one person on here who had this issue being caused by Cerberus. I briefly had Cerberus on my phone but the trial expired and I never paid, so it basically just sat on my phone unused. I couldn't uninstall because my account had been deleted on the site. Since the factory reset, Cerberus doesn't even show up as an app.

This had been going on for a few weeks now and I've read as much as I can but I'm at a loss. Anyone have some advice for what my next steps might be?


p.s. Sorry for typos or long paragraphs. Typing from my phone so I can't really tell how readable this is!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes