Enable the Hidden Notification LED on the Google Nexus 6!

LED notification lights have existed on Android devices since the very beginnings … more

MX Player Ready to Rock on Lollipop

A good video player should be reliable and free. One of the XDA Community Apps, MX Player, meets both of … more

How to Disable Data Encryption on Nexus 6

In late September, Google decided to step on NSA’s toes and turn on encryption by default in … more

DJI Phantom 2 Vision+ Review – XDA TV

The holidays will be here in no time, so why not start thinking about gifts now? Youll be ahead … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

k2_CL RUU freezing @ black HTC screen

OP tootone

24th May 2014, 08:14 PM   |  #11  
tootone's Avatar
OP Member
Thanks Meter: 43
 
87 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by Modding.MyMind

What shows on your device screen when doing it?

Also, if you are S-On and was on 4.2.2 prior to your device giving problems then it will fail because the RUU is 4.1.2 and would require a "downgrade" which can only be achieved if S-Off.

With that said, I went back up on this thread and saw you are having problems with TWRP. Make sure you are using the correct one. Should be 2.7.0.2d or 2.7.0.2c. If attempting to flash another version and you are on 4.2.2 then you will get boot problems with the recovery.

In addition, make sure your bootloader isn't locked if S-On while messing with TWRP or that will cause a security problem on your device.

Sent from my C525c using Tapatalk

bootloader is unlocked but I am s-on maybe that is causing all of my problems. I will see what I can do to remedy that. Well nevermind, I can' t s-off without a working rom, and I can't get a working rom without s-off.
Last edited by tootone; 24th May 2014 at 08:30 PM.
Modding.MyMind
24th May 2014, 08:45 PM   |  #12  
Guest
Thanks Meter: 0
 
n/a posts
Quote:
Originally Posted by tootone

bootloader is unlocked but I am s-on maybe that is causing all of my problems. I will see what I can do to remedy that. Well nevermind, I can' t s-off without a working rom, and I can't get a working rom without s-off.

Hmm, well, there is one thing I know for sure and that it that you are definitely able to restore your phone, so I'm pretty sure that some attempts being made In regards to trying other methods are possibly not being done exactly like they should.

This device is VERY hard to wreck and I have done LOTS to my phone and have always been able to bring it back to life in 5 minutes or less.

Sent from my C525c using Tapatalk
24th May 2014, 08:55 PM   |  #13  
tootone's Avatar
OP Member
Thanks Meter: 43
 
87 posts
Join Date:Joined: Jul 2010
I am fairly certain I am doing it right. My mistake here was not doing a backup before I flashed anything. Let me go through what I had tried.

The RUU, I run it with my bootloader locked and I get error 158, I run it unlocked, I still get error 158.

I have tried the rom from the RUU, fastboot into ruu mode, transfer it, and I get an error

I tried putting PL80IMG in the root of my sd, it seems to flash correctly but it boots in white htc quietly brilliant screen. and flash boot.img for that rom.

I restore a rom via TWRP boots into white htc quietly brilliant screen.

and countless other things.
24th May 2014, 09:04 PM   |  #14  
old.splatterhand's Avatar
Recognized Contributor
Flag Saturn III
Thanks Meter: 1,654
 
2,788 posts
Join Date:Joined: Nov 2010
Donate to Me
What about the other backups for boost (older than 4.2.2), does none of them work?
Modding.MyMind
24th May 2014, 09:11 PM   |  #15  
Guest
Thanks Meter: 0
 
n/a posts
Quote:
Originally Posted by tootone

I am fairly certain I am doing it right. My mistake here was not doing a backup before I flashed anything. Let me go through what I had tried.

The RUU, I run it with my bootloader locked and I get error 158, I run it unlocked, I still get error 158.

I have tried the rom from the RUU, fastboot into ruu mode, transfer it, and I get an error

I tried putting PL80IMG in the root of my sd, it seems to flash correctly but it boots in white htc quietly brilliant screen. and flash boot.img for that rom.

I restore a rom via TWRP boots into white htc quietly brilliant screen.

and countless other things.

1. RUU won't work because it's 4.1.2 and you were on 4.2.2. The RUU has the HBoot in it and your device will not allow the HBoot to be downgraded because you are S-On. Only time you can use an RUU is if it is equivalent to 4.2.2 which one does not currently exist for us.

2. PL80IMG.zip's only work for those who are S-Off. Which is why it won't work for you.

3. When you restore your device using TWRP you ALSO have to rename boot.emmc.win to boot.img and flash it using fastboot:
Code:
fastboot flash boot boot.img
-- This is because, once again, you are S-On and cannot write to your boot partition EXCEPT using fastboot. You could using dumlock but to get dumlock initially set up for the first time would require your device to be able to load an OS so for you that is currently out of the question.

You must restore your device using a twrp backup, AND NOT REBOOT THE SYSTEM when it is done.

Instead, reboot the bootloader, and using fastboot, flash the boot.img which comes with the twrp backup as I just stated earlier.

Then you may reboot.

That will ALWAYS work, so if it fails, then this is an end user problem.


Sent from my C525c using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes