Mozilla Ditches Google, Makes Yahoo Default Search Engine

Mozilla and Google have had a long-standing relationship of about 10 years. Google … more

Learn More About Linux with Linux Man Pages

Linux is quite a powerful and very configurable operating system. Thanks to some user-friendly … more

Detect, Avoid IMSI-Catcher Attacks with Android IMSI-Catcher Detector

Privacy is always an important topic, as well as a delicate one to … more

Materialized LeanDroid Fights Your Poor Battery Life

Battery life has always been one of the biggest problems facing most Android devices. … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[MOD] Disable home button wake

OP cam30era

26th January 2013, 01:28 PM   |  #21  
Junior Member
Thanks Meter: 1
 
21 posts
Join Date:Joined: Oct 2007
You can change the first part from HOME to POWER and make it work literally like a power button. But then it won't work as a home button AT ALL.
31st January 2013, 10:44 PM   |  #22  
tdrussell's Avatar
Senior Member
Flag Dallas
Thanks Meter: 134
 
728 posts
Join Date:Joined: Sep 2010
Any modification of this file on my device results in both my home key and power key becoming completely nonfunctional.
31st January 2013, 10:49 PM   |  #23  
stu5797's Avatar
Senior Member
Flag Cleveland, Ohio
Thanks Meter: 215
 
1,334 posts
Join Date:Joined: Aug 2011
More
I don't think you followed the directions 100%. Good thing a backup is saved automatically
31st January 2013, 11:27 PM   |  #24  
tdrussell's Avatar
Senior Member
Flag Dallas
Thanks Meter: 134
 
728 posts
Join Date:Joined: Sep 2010
Quote:
Originally Posted by stu5797

I don't think you followed the directions 100%. Good thing a backup is saved automatically

No, it's either a result of using ES FIle Explorer or a conflict with Beans.

The contents of that file is:
Key 115 VOLUME_UP WAKE
KEY 114 VOLUME_DOWN WAKE
KEY 116 POWER WAKE
KEY 172 HOME WAKE

If i change the last line to any of the following, i lose use of the home and power keys:
KEY 172 WAKE
KEY 172
KEY 172 POWER
KEY 172 WAKE POWER
KEY 172 POWER WAKE
KEY 172 WAKE_DROPPED
28th March 2013, 05:20 PM   |  #25  
Member
Thanks Meter: 9
 
60 posts
Join Date:Joined: Jul 2012
More
Quote:
Originally Posted by jsadler09

Thanks, I use widget locker and its home helper seemed to help with the home button unlocking directly to the home screen, but it didn't help with the power amp pro lock screen. I'll give this a try.

How do I set up Widgetlocker to stop taking me to home screen when I press the home button? I tried playing around with Home Screen Helper but I can't seem to get the setting right. Do you mind giving me a quick walkthrough? Thanks!
23rd April 2013, 05:48 AM   |  #26  
harajyuks's Avatar
Senior Member
Flag Englishtown
Thanks Meter: 105
 
335 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Quote:
Originally Posted by cam30era

I take no credit for this. Did a Google search and found it on the Sprint Gnote 2 XDA forum. I tried it and it works on our Verizon Gnote phone.

All credit goes to ffolkes:


1. Mount as R/W and open /system/usr/keylayout/gpio-keys.kl.

2. Scroll to the line that says:
"key 172 HOME WAKE"

3. Now delete the HOME so it says:
"key 172"

4. Save it and reboot.


PS: Long hold the file and choose the option "open with text editor".



Sent from my SCH-I605 using Tapatalk 2

That's the home button disable mod. Thanks to the op

---------- Post added at 11:48 PM ---------- Previous post was at 11:46 PM ----------

What's going on with me trying to post this?

Quote:
Originally Posted by cam30era

I take no credit for this. Did a Google search and found it on the Sprint Gnote 2 XDA forum. I tried it and it works on our Verizon Gnote phone.

All credit goes to ffolkes:


1. Mount as R/W and open /system/usr/keylayout/gpio-keys.kl.

2. Scroll to the line that says:
"key 172 HOME WAKE"

3. Now delete the HOME so it says:
"key 172"

4. Save it and reboot.


PS: Long hold the file and choose the option "open with text editor".



Sent from my SCH-I605 using Tapatalk 2

That's the disable home button mod, thanks to the op(s)

Sent from my SCH-I605 using Tapatalk 2
25th April 2013, 02:27 AM   |  #27  
Member
Thanks Meter: 9
 
60 posts
Join Date:Joined: Jul 2012
More
This worked perfectly for me. Does anyone know what I'd need to modify in order to get the following?

1. Change longpress Home to activate Multiwindow bar. (instead of recent apps)
2. Change longpress Back to activate recent apps. (instead of Multiwindow)

17th April 2014, 06:26 PM   |  #28  
Junior Member
Thanks Meter: 5
 
14 posts
Join Date:Joined: Dec 2010
Same things works on xcover 2, thanks.
25th May 2014, 12:18 AM   |  #29  
Senior Member
Flag Las Vegas
Thanks Meter: 22
 
350 posts
Join Date:Joined: Jan 2008
If you are rooted, just use Wanam Xposed.

Sent from the Note II

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes