Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,784,939 Members 51,083 Now Online
XDA Developers Android and Mobile Development Forum

Brand new Galaxy S4 MK2; Hyperdrive Bluetooth issues

Tip us?
 
xaero252
Old
#1  
Member - OP
Thanks Meter 4
Posts: 39
Join Date: Oct 2009
Default Brand new Galaxy S4 MK2; Hyperdrive Bluetooth issues

I had an unlocked S4, which took an unfortunate dive and ended up non-functioning. I used my phone insurance to acquire a new (unfortuantely) updated phone running the full MK2 suite. First order of business was a root & install of SafeStrap, followed by installation of Hyperdrive to Rom Slot 1. I use my phone with my 2013 Subaru XV Crosstrek's bluetooth handsfree for both calling and media playback, and I use this feature EVERY SINGLE DAY. Unfortunately, not any more. I cannot get more than 15 seconds of connected time over bluetooth with the phone. I've tried multiple wipes. I'm fairly certain the issue doesn't exist on stock rom; so I may end up just customizing a stock rom in slot 1 by removing absolutely everything and building it from the ground up, since I don't have to use the (apparently buggy) mk2 modules.

Edit:
I'm seriously considering selling this phone and getting something more friendly to modding, this is a repeat of the Droid Bionic at this point.
 
decaturbob
Old
#2  
Senior Member
Thanks Meter 809
Posts: 2,383
Join Date: Mar 2011
Location: Decatur
Is there a question here? Did the stock rom blue tooth work ok?

Sent from my SCH-I545 using XDA Premium 4 mobile app
so long Verizon and my awesome S4 , hello TMO G3
 
xaero252
Old
(Last edited by xaero252; 17th March 2014 at 03:35 AM.)
#3  
Member - OP
Thanks Meter 4
Posts: 39
Join Date: Oct 2009
And this is why I shouldn't hastily write a post.

Yes there should be a question:

What can I try to fix the issue of frequent (alarmingly) bluetooth disconnects?
What kind of logging can I do to try and help provide developers with the information to fix this?
Anybody else have this problem? Any experience fixing it?

If I can't get this fixed, I have no choice but to move to another phone. Preferably at Verizon's expense.


Even more irritating: The phone is listed as compatible with the Crosstrek. I'm going to test that it works fine using the stock rom and bluetooth, and factory resetting my head unit.
 
s.whiplash
Old
#4  
Member
Thanks Meter 2
Posts: 34
Join Date: Dec 2007
Did you install the MK2 modules after installing Hyperdrive?
 
xaero252
Old
#5  
Member - OP
Thanks Meter 4
Posts: 39
Join Date: Oct 2009
Quote:
Originally Posted by s.whiplash View Post
Did you install the MK2 modules after installing Hyperdrive?
Yes. Originally when I installed it WiFi and Bluetooth didn't work at all. I realized quickly my error was the lack of installing the MK2 modules. I wiped and installed again, this time ensuring the MK2 modules followed the rom install. I got everything set up the way I like to, and began day to day use of the phone. Since then I have had the bluetooth connectivity problems I described above.
 
xaero252
Old
#6  
Member - OP
Thanks Meter 4
Posts: 39
Join Date: Oct 2009
Bluetooth is rock solid on stock. I'd really rather not have to play this game where I can install stock or.... basically stock... and now that I'm locked kernel and radio wise if I have issues further with OTAs I'm just as stuck with a near useless phone as I was with my Bionic
 
s.whiplash
Old
#7  
Member
Thanks Meter 2
Posts: 34
Join Date: Dec 2007
I'm afraid that I don't have anything else for you, except try a different ROM. Bonestock or Eclipse? Bluetooth works pretty good for me with multiple headsets and vehicles. My only issue with Bluetooth is not all the apps will pass metadata to my truck. This happens with all 3 of these ROMs and I think it is a TW 4.3 limitation.

Are you doing anything to boost the Bluetooth volume? With my previous phone I boosted the Bluetooth volume via some hacks and my truck would not like it.

I know what you mean about having a locked down phone. I came to the S4 via a warranty replacement from an unlocked S3 running SlimBean and SlimKat.The problem is that most of the new phone that are coming out all have bootloader hurdles.
 
myb120
Old
#8  
Junior Member
Thanks Meter 2
Posts: 10
Join Date: Jan 2014
I'm having the same issue with my SGH-M919 (T-Mobile) running rooted stock TW. I've documented my issues and a few LogCats here. Have you figured out a solution?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Give Your Notification Shade a Facelift with these Modding Guides

Modification has always been one of the strong suits of Android, due in … more

Keep Track of How Much Your Car Truly Costs with Car Logbook

It’s a very well established fact that cars are expensive. In addition to … more

New Nvidia SHIELD Tablet OTA! Moto G 4G Gets Official CyangenMod 11 Nightlies – XDA Developer TV

The Nvidia SHIELD Tablet gets its … more

Prevent Apps from Locking Screen Orientation with HaveOwnOrientation

Most applications on Android play nicely with both landscape and … more