Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,310 Members 45,270 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Help me choose correct files and order for Odin-ing

Tip us?
 
LordHelmchen138
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 19
Join Date: Dec 2012
Default [Q] Help me choose correct files and order for Odin-ing

Greetings!

I urgently need help to verify what files and in what order to flash to restore my GF's Note2:
It's a GT-7100 that is still on 4.1.1 and eMMC Brickbug Check app reports it as SDS vulnerable... original firmware, execpt for Exynos Abuse, SuperSU and AFwall+, but that was apparently enough to trigger "modified" state and so prevent OTA updates. Installing Wanam Exposed to hide modificatioon did not work, so we unrooted, but forgot to reverse Exynos Abuse fix. Now we're still unable to OTA, but without root as well

I think the next best step will be to flash to 4.3 via Odin and then apply saferoot from cosmyndemeter.

To prevent any warranty issues, I would prefer to keep the phone knox-free, which means that 4.4 update is not an option, and I need the botloader to keep to version mj5 or below.

I got N7100XXUEMK9_N7100VIAEML2_VIA.zip from sammobile.com, which seems applicable (region- and operator-wise), and BL_MJ5_DN3.rar for the unknoxed bootloader.

If I simply flash those two files, will that already trigger a reaction from knox (preventing any future BL-upgrades) or am I safe as long as the phone does not reboot between the two flash processes?
 
erljayp
Old
#2  
erljayp's Avatar
Senior Member
Thanks Meter 46
Posts: 204
Join Date: Dec 2012
Quote:
Originally Posted by LordHelmchen138 View Post
Here's what I know.sorry if i cant answer all.

-Stock firmwares from sammobile or other site already have a bootloader included with it, no need to flash other BL.
-Not sure if the bootloader from the MK9 is MJ5 or below, please search.
-Knox enabled bootloaders are upgradable, but can no longer have downgrade.
-If based from your search that MK9 base has a bootloader MJ5 or below, you are good to go.backup and flash via odin.
-Else, find an older rom base with BL MJ5 or below from sammobile.

Good luck. ^.^

Sent from my GT-N7100 using XDA Premium 4 mobile app
 
LordHelmchen138
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 19
Join Date: Dec 2012
Well... I decided to go a longer way that seemed a bit safer:
- got N7100XXDLL4_N7100VIADLL2_VIA from sammobile, which is still exynos-abusable.
- rooted with exynosAbuse
- installed Mobile Odin
- flashed the aforementioned N7100XXUEMK9_N7100VIAEML2_VIA with Mobile Odin, relaxing in the knowlege that Mobile Odin will not flash the bootloader
- flashed the aforementioned mj5 bootloader only with Odin
- unsuccessfully flashed UPDATE-SuperSU-v1.94.zip with Mobile Odin. I guess this was stupid
- rooted with saferoot

result:
rooted phone on 4.3 , so far so good.
Phone Info app reports:
Code:
Knox Warranty Void: 0x0
Bootloader Version: N7100XXUEMJ5
Baseband Version: N7100XXUEMK9
PDA Version: N7100XXUEMK9
CSC Version: N7100VIAEML2
Only my noobishly overoptimistic attempt at rerooting is now visible:
Code:
CUSTOM BINARY DOWNLOAD: yes (1 counts)
CURRENT BINARY: Samsung Official
SYSTEM STATUS: custom
WARRANTY BIT: 0
Can anyone reassure that mj5 bootloader means that knox warranty void cannot trigger, so using triangle away is safe ? I'm still slightly worried that the bootloader simply does not display the knox bit, but that it is still 'primed' in the background and just waiting to blow up...
 
singhpratik87
Old
#4  
singhpratik87's Avatar
Senior Member
Thanks Meter 1489
Posts: 2,498
Join Date: Sep 2010
Quote:
Originally Posted by LordHelmchen138 View Post
Code:
Knox Warranty Void: 0x0
Bootloader Version: N7100XXUEMJ5
Baseband Version: N7100XXUEMK9
PDA Version: N7100XXUEMK9
CSC Version: N7100VIAEML2
Only my noobishly overoptimistic attempt at rerooting is now visible:
Code:
CUSTOM BINARY DOWNLOAD: yes (1 counts)
CURRENT BINARY: Samsung Official
SYSTEM STATUS: custom
WARRANTY BIT: 0
Can anyone reassure that mj5 bootloader means that knox warranty void cannot trigger, so using triangle away is safe ? I'm still slightly worried that the bootloader simply does not display the knox bit, but that it is still 'primed' in the background and just waiting to blow up...

Knox warranty void 0x0 means the bootloader didn't trigger the Knox but honestly after a point we should all stop caring about Knox ( unless you use it for business purposes or still under warranty ). Now you can flash any custom KitKat ROM and be on Mj5 bootloader. Only thing is that phone won't charge when turned off ( draw back of mj5 and other jelly bean bootloaders ) only being on KK boot loader can charge your phone when turned off . here you got two options if you only flash nd3 bootloader after upgrading to custom KK ROM it will trigger Knox and it will show 0x1 or you can flash the official stock KK rom via odin that will flash the ND3 boot loader and knox remains 0x0 since its an official ROM . So it depends on you what do you plan on doing on your note II ,if you want to try newer ROMs or stick to 4.3 based ROMs


Sent from my GT-N7100 using Tapatalk
 
LordHelmchen138
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 19
Join Date: Dec 2012
Well, the phone is not mine, and there's still about six months of warranty left. So yes, I still have to care about knox
As it stands, 4.3 and mj5 bootloader look fine, so it's only the flash counter and system :modified that I want to take care of.

Sent from my D5503 using XDA Free mobile app
Tags
knox, odin
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes