Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,629 Members 41,520 Now Online
XDA Developers Android and Mobile Development Forum

Could someone please help unbrick my Sprint LG G2 with TMOBILE ROM?

Tip us?
 
htc fan89
Old
#31  
htc fan89's Avatar
Senior Member
Thanks Meter 200
Posts: 3,627
Join Date: Jun 2009
Location: Ottawa,Vaudreuil-Dorion and NYC

 
DONATE TO ME
Quote:
Originally Posted by pm.mohanani@gmail.com View Post
i too have same prob..

if u got solved then plz let me know about it..


also require the adb sidelod supportable ROM.
read my post, it tells how to get it back to sprint rom...

1) Get custom recovery on your phone
2) by using adb side load sprint rooted stock rom ( so, it would become a sprint G2 again from being an t-mobile g2, that's the reason it fails in lg flasher tool)
3) Now, once it flash successful, boot into downloader mode. Then flash stock sprint rom via lg flasher tool.
Asus transformer tf300 torch red()
unbranded htc one m8(sexy)



 
beeroatsnp90x
Old
#32  
Senior Member
Thanks Meter 21
Posts: 247
Join Date: Aug 2010
if sideload doesn't work (sideload didn't work for me) I just used adb push instead of adb sideload.

you just adb push "name of rom" to /sdcard/0. if you are bootlooping the problem is that you didn't downgrade aboot and maybe forgot to downgrade radio. You need to do this: adb push the zv8 radio and zv7 boot to sdcard in recovery to /sdcard/0

for example in my case:

Type adb push zv7-aboot.img /sdcard/
Type adb shell
Type dd if=/sdcard/zv7-aboot.img of=/dev/block/platform/msm_sdcc.1/by-name/aboot

then adb push zv8radio.zip /sdcard/0
after you downgrade your aboot with the above commands, flash the cm11 rom and gapps. then flash the zv8 radio. You will then be able to boot. Hope this helps anyone that needs specific instructions on what to do if they softbricked their g2 on zva and didn't downgrade aboot or flash zv8 radio.
 
SPASuka
Old
#33  
Junior Member
Thanks Meter 0
Posts: 9
Join Date: Oct 2008
Some problem with flash t-mobile rom to ls980.
But I was back to stock. Now imei and modem is unkown.

I can`t flash custom recovery - no luck by program, and no luck by ADB. stuck in su request (root was made)
Any help?

Sorry for my English.
Thx
 
milkshed27
Old
(Last edited by milkshed27; 20th April 2014 at 10:03 PM.)
#34  
Member
Thanks Meter 9
Posts: 48
Join Date: Jun 2010
mispost
 
chinocjm
Old
#35  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Mar 2014
Smile i have the exact same problem

hello im glad it worked for you ive been struggling with the same problem for 2 months already and nothing had worked for me...can u help me and explain to me how to do this procces please i have the same lg g2 ls980 flashed with the tmobiles firmware d801 and with the flash tool always give me different model error
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes