Post Reply

[Q] Dead GPS

OP adsbar

20th May 2014, 09:01 PM   |  #1  
OP Member
Thanks Meter: 8
 
84 posts
Join Date:Joined: Jul 2006
More
Hoping for some help with my GPS issues.

I have a 32G Nexus 7 2012 Wifi.
GPS has worked on it in the past - I was using Copilot.
Haven't used the feature in a while.
Currently on the most recent official PA ROM.
Tried to use Copilot, got no satellites. Downloaded every GPS app (free) I could find, approx 5 of them. I have reset the GPS several times, and downloaded AGPS data. The apps show that the GPS is turned on (it says GPS off when off). At each trial, I stand outside under open sky for 3-10 min.
Just for fun, tried Franco kernel, no change.
I have checked location settings, and tried both with all location services as well as GPS only.
Multiple reboots attempted.
Popped off the back, looked at GPS contacts - they are intact. I bent them carefully up a little, no dice. I believe they probably hit the contacts on the back cover antenna, but of course I can't be sure.

My next attempt will be to put a little bead of solder on the contacts on both the spring contacts and the flat contacts on the back cover. If that doesn't do it, I'm out of ideas. I can do a full wipe, but I'd like to exhaust all other options first. The last time I had GPS working was before Kitkat. However, search does not show anything helpful with my issue.
22nd May 2014, 07:34 AM   |  #2  
OP Member
Thanks Meter: 8
 
84 posts
Join Date:Joined: Jul 2006
More
Still dead
Building up the contacts with solder did nothing.

Finally bit the bullet and reflashed to latest CM11 nightly (5/20/14). Still dead.

This seems to point to a hardware problem. Anyone have any ideas on how to troubleshoot? I was hoping to use my N7 as my GPS when I move from Wisconsin to Texas next month.
22nd May 2014, 05:02 PM   |  #3  
exglynco's Avatar
Senior Member
Flag Bay Area
Thanks Meter: 15
 
101 posts
Join Date:Joined: Nov 2012
Sandwich little bits of aluminum foil between the contacts and the gps antenna. Sorry for the outdated suggestion. Have you checked these considerations?

Sent from my Nexus 7 using Tapatalk
Last edited by exglynco; 22nd May 2014 at 05:10 PM.
26th May 2014, 07:22 PM   |  #4  
Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Feb 2009
I had the same problem with many different Roms on my N7. Finally I have found a solution in the web:
1) Generate the directory /data/gps
2) Change the directory access rights to 775, i.e. RWX RWX R-X

Already then everything should work fine, otherwise perform a reboot.
You will see in the new directory a file named "gps.interface.pipe.to_gpsd" plus some others.

Currently this solution is working fine for me with a cm11 nightly 23.5.2014 (also before with the milestone version).
Post Reply Subscribe to Thread

Tags
gps
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 7 Q&A, Help & Troubleshooting by ThreadRank