Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Won't turn on

OP Kabir999

24th May 2014, 06:13 PM   |  #1  
OP Member
Thanks Meter: 4
 
89 posts
Join Date:Joined: Feb 2012
My Xperia SP won't turn on for some reason. The phone is stock and had full charge when this happened. It just got shut down and now it just doesn't respond. Even when I connect it to power it is completely shut down.

Any advise?
24th May 2014, 09:06 PM   |  #2  
Member
Flag Skierniewice
Thanks Meter: 1
 
31 posts
Join Date:Joined: Nov 2011
More
Did you try hold OFF button behind the phone?
24th May 2014, 11:41 PM   |  #3  
OP Member
Thanks Meter: 4
 
89 posts
Join Date:Joined: Feb 2012
Quote:
Originally Posted by Cripex

Did you try hold OFF button behind the phone?

Yeah I did. It still didn't work.
25th May 2014, 08:27 AM   |  #4  
greek_assassin's Avatar
Member
Thanks Meter: 25
 
73 posts
Join Date:Joined: Apr 2014
More
Try the off button with no sim card on the phone

Sent from my C5303 using XDA Premium 4 mobile app
26th May 2014, 09:23 PM   |  #5  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: May 2014
It worked!
Quote:
Originally Posted by greek_assassin

Try the off button with no sim card on the phone

Sent from my C5303 using XDA Premium 4 mobile app

I tried to clear the cache from my phone and it passed away.
Wouldn't turn on.

When I tried the off button on the back I was already with no sim card.
It worked on the first try, about five seconds holding the button.

Tks!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes