Post Reply

[Q] Can't access sdcard in recovery mode

26th May 2014, 11:10 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: May 2014
I want to upgrade my GT-P7310 from Samsung's version of Android 4.0.4 to CM 10.2 but I can't get root/su or Clockwork Recovery installed. When I go into recovery mode and select "apply update from external storage" it shows the error:

E:unknown volume for path [/sdcard]

There's an option to "apply update from cache" too, but /cache isn't writable without root.

I tried the downloading option (Odin) too, using Heimdall for Linux, but the recovery images I've downloaded aren't compatible with that (even after repacking from zip to tar.gz).

I also tried Bin4ry's rooting package (v33), but even after fixing the obvious bugs fixed it depends on remounting /system rw which doesn't work.

Does anyone know how to fix the unknown volume error or how to get Odin to work (preferably with Linux (Heimdall) rather than Windows)?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes