Default My Inspire 4G (randomly?) stopped successfully booting and cannot access bootloader

I have a rooted and bootloader-unlocked Inspire 4G. A few months ago, I had been using the MoKee 4.2.2 ROM for some time, and one day, my phone's screen simply froze. I thought I shouldn't be worried about it, so I pulled the battery off, slapped it back in and tried turning on the phone again. It never got past the MoKee loading screen. I tried charging it, leaving it to boot for hours but nothing.

Next, I tried rebooting into CWMrecovery to try different stable backups I had from some time before that happened. The backups restored successfully, but again, the phone stayed stuck in the loading screen. I tried the same with 4EXT Touch Recovery and wiping all the data before the backup, but still nothing worked.

Since I was too busy at the time to install a new ROM and flash a new boot image, I decided to put the phone away and use my backup Galaxy Ace. Today, a few months after that happened, I tried to boot the phone into bootloader and I can't even achieve that. Holding the volume down rocket and power buttons, the phone still boots normally and stays stuck on the loading screen.

What weirds me out the most is that this was all random--I did not drop the phone or did things to it that could break it.

I feel if I could get into recovery I'd be able to do something else about it.

Any ideas?