Unhappy [Q] Super Fast Crazy Battery Drain on Cyanogenemod 11 Nightly Solution Needed

I just installed CM 11 on my xperia V but then I'm experiencing this terrible super fast battery drain. It's been 3 days. The first night I installed it it drained my whole battery while I was asleep. Usually standby time is great before I installed CM 11. Maybe its because of the sony stamina extended standby mode thingy. Last night, I reckon that it's probably because of the background process and the wifi, so I reboot the phone (so that all apps are killed) and didn't turn on the wifi. It eats 7% of my battery. Dafuq???

So, I checked the battery stats and 82% of my battery is used on android system. Then, I turned off location access. Brightness is at its lowest. It was on aeroplane mode. Bluetooth is off. I underclock the device to clock only at 1 ghz and i clear all recent apps. Only the wifi is turned on. I only left it for half an hour without even touching it but my battery went down from 100% to 93%.!!! Can you imagine?? This sucks. Can anyone please help me with this issue? Imagine after an hour my battery would be at 80%. That means i can only use the phone for 5 hours!! That is without any connectivity at all with slow processor and low brightness. If I were to push it to the max it would take maybe 2 hours of usage. I uploaded the battery stats included with this thread.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-05-27-10-11-58.png
Views:	3
Size:	154.0 KB
ID:	2765021