Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,490 Members 44,403 Now Online
XDA Developers Android and Mobile Development Forum

[Q] RAZR M stuck on eHRPD - cannot get LTE

Tip us?
 
praetorzero
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Dec 2010
Phone [Q] RAZR M stuck on eHRPD - cannot get LTE

All -

I recently purchased a used RAZR M for my wife. She enjoyed borrowing my work phone, so I figured she'd like this. Except I can't get the damn thing to switch to an LTE band. I've swapped sim cards and thrown mine in, same thing. No 4G. I've compared it to my work phone and the settings *look* to be correct. In the same room, my work phone gets LTE, so I know it's not a signal strength issue where I am.

I don't know the history of the phone itself. Would this be the result of it being switched to GSM use? Is this a radio problem? Is this a firmware problem? Is this a PEBKAC issue?

Keep in mind, this is on stock. I'm not too keen on being stuck on stock, I don't have a lot of choices with it being locked and on KitKat right now.

I'd appreciate any help/insight that y'all can offer.
 
praetorzero
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Dec 2010
Still looking for some insight. For what it's worth, the phone is being used on VZW now, it just can't / won't get LTE.
 
DiamondJohn
Old
#3  
Senior Member
Thanks Meter 31
Posts: 172
Join Date: Aug 2013
Location: Sydney
Check with your provider that you are using the correct APN for LTE. I know my provider has a specific APN for LTE and another that will only connect using 3G. It took multiple calls to their broadband tech support before someone pointed me to the correct APN config.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes