Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,749 Members 51,053 Now Online
XDA Developers Android and Mobile Development Forum

Phone unusable while plugged into USB

Tip us?
 
pcxnet
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Nov 2007
Plug Phone unusable while plugged into USB

Im trying to help my friend with his Xperia Z1. A couple of days ago, it reboot when it got plugged into charge. Then after that, everytime its connected to USB the phone becomes unusable.

Its completely stock 4.4.2 and while plugged into USB it becomes really really hot, battery discharges about 10% every minute or so and the screen flickers and can't be used (Feels like 100% cpu usage).

When you go into running apps, you can't see it because it constantly refreshes the list, and when its plugged into a computer, it works for a few seconds and then stops responding.

It works perfectly while not charging, and can be charged using the magnetic plug (Dock). Plugging into stock charger USB, car usb, or a computer all results in a freeze up/100% cpu usage etc If the phone is completely off, it can charge up very slowly while using USB and does not get hot, however the fastest way to charger it is via the dock option.

This is Australian stock, and is the second phone he has had to do this, his first phone he bought in Nov 2013, updated it to a 4.3 build in December and it did a similar thing, got this late December 2013, and has lasted until now, and is unusable while connected to USB.

This means it can't be updated, backed up, rooted or anything and sony want it to be sent away for weeks. Has anyone had any similar problems or know of a solution. It doesn't feel like its a hardware thing, but possibly something has shorted in the plug.. Not sure?

Thanks
 
dladz
Old
(Last edited by dladz; 26th May 2014 at 10:43 AM.)
#2  
dladz's Avatar
Senior Member
Thanks Meter 729
Posts: 3,577
Join Date: Aug 2010
Location: Liverpool

 
DONATE TO ME
Quote:
Originally Posted by pcxnet View Post
. Has anyone had any similar problems or know of a solution. It doesn't feel like its a hardware thing, but possibly something has shorted in the plug.. Not sure?

Thanks
Haven't had this issue myself but it does sound like a hardware problem rather than software, but software could also be to blame too.

It's probable because the phones on pure stock that it's the apps that are installed on the phone.

To eliminate this, make a back up of media files like pics, videos, music. Then flash an FTF file so that you have bare bones stock.

These can be found in the mega collection in the general section.

Run some tests on the charging capabilities whilst it's completely stock and empty and you'll then know if it's a hardware issue or not, if the problem re occurs then it's hardware, if not then it's probably something that was installed or a load of things that were installed.

If it's the latter then try to reduce whats coming in and out of the phone, having a tonne of apps with a large footprint is going to bring any phone to it's knees and that's with any phone or even a tablet.

I don't think flashing an FTF while in flashmode should do much harm and the OS isn't loaded at this point either so the load should be minimal, if he or yourself are not comfortable with this then i'd suggest biting the bullet and sending it off to Sony.

Hope this helps.
Phones: Moto 888 - Nokia 6110 - Nokia 3210 - Nokia 3310 - Nokia 8210 - Samsung e250 - Sony F305 - LG Viewty - G1 - HTC Hero - HTC Desire HD - HTC Sensation - Nokia Lumia 800 - HTC EVO 3D - Samsung i9300 - Asus Prime TF201 silver - HTC One - Galaxy Camera - Z1
 
Lord Takyon
Old
#3  
Lord Takyon's Avatar
Senior Member
Thanks Meter 182
Posts: 1,428
Join Date: Jul 2010
Might not be the same, but I had this on the xperia s. Turned out the USB lead was defective.

Sent from my C6903 using XDA Premium 4 mobile app
 
pcxnet
Old
(Last edited by pcxnet; 26th May 2014 at 12:16 PM.) Reason: Added question
#4  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Nov 2007
Quote:
Originally Posted by dladz View Post
To eliminate this, make a back up of media files like pics, videos, music. Then flash an FTF file so that you have bare bones stock.
.
Hi Dladz, thanks for the suggestion, can the FTF be flashed if its not rooted ? I dont know much about sony, I have a rooted/rommed LG G2, but not sure about the Sony files.

Also, can I flash it if I can't connect it to USB ?

And to the other reply, its definitely not the lead ,we've tried about 10 different leads.
 
romaha
Old
#5  
Junior Member
Thanks Meter 7
Posts: 25
Join Date: Jun 2010
Location: Novosibirsk
Hi, I've had the same issue.
Try to plug in USB, than use system info *#*#4636#*#* -> Battery information
Look on "Battery status" line (dont know exactly how it sound on english ROMs) if youre see permanently changing status Charging (USB) <-> Battary the 90% probability you have hardware problem.

I fix it only in sony service center with motherboard change.
Tags
charge, problem, usb, xperia
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes