Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Need Help with ROM/Partition Errors on GT-i9500

OP krtk6160

26th May 2014, 08:45 PM   |  #1  
OP Junior Member
Flag Indore
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2014
More
So guys, I think I'm in a real big problem. When I flash PAC Rom on my i9500 and reboot, it says "System UIDs Inconsistent. UIDs on the system are inconsistent, you need to wipe your data partition or your device will be unstable."
I rebooted into TWRP recovery, Fixed Permissions, and the problem disappeared. However, after that, when I tried to install Apps from File Manager, it said Application Not Installed. I believe this has something to do with the partition thingy. Is there anyway I can overcome these problems?

The problem started when I wanted to install LiquidSmooth on my device. When I tried to do Nandroid backup through TWRP, it failed. Twice. So I used adb for the backup, but it was copying the whole block, 3-4GB+, was taking too much time, so I aborted it in the middle of the process. I then went to TWRP, and flashed LiquidSmooth without wiping (I forgot to wipe). The ROM didn't work, got stuck into Android is Upgrading, even after I wiped, still had the same problem. So I decided to restore my failed backup of the previous ROM (AICP). When rebooted, everything was crashing, System UIDs Inconsistent and stuff. Flashed PAC ROM, still the System UIDs problem, but fixed that with Fixing Permissions.

Is there anyway I can get my phone back to normal? Will I have to re-partition? What are the possible fixes?
Last edited by krtk6160; 26th May 2014 at 08:49 PM. Reason: Better Layout
27th May 2014, 07:00 AM   |  #2  
OP Junior Member
Flag Indore
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2014
More
Is there no one who can help me?
27th May 2014, 07:27 AM   |  #3  
Senior Member
Thanks Meter: 480
 
963 posts
Join Date:Joined: Sep 2013
More
Quote:
Originally Posted by krtk6160

Is there no one who can help me?

I think you partitioned your card as Logical make the partition as type primary.. then flash the ROM..
27th May 2014, 08:10 AM   |  #4  
OP Junior Member
Flag Indore
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by shubhojit89

I think you partitioned your card as Logical make the partition as type primary.. then flash the ROM..

I had recently erased the SD card THROUGH the option available in the phone settings. But the System UIDS problem was there before I did this. I didn't change the partition type. And the SD card contained some android data and obb files. Might that be the problem?
Also, should I just put it into the SD card slot in my laptop and format with the Windows Utility?
27th May 2014, 08:27 AM   |  #5  
Senior Member
Thanks Meter: 480
 
963 posts
Join Date:Joined: Sep 2013
More
Quote:
Originally Posted by krtk6160

I had recently erased the SD card THROUGH the option available in the phone settings. But the System UIDS problem was there before I did this. I didn't change the partition type. And the SD card contained some android data and obb files. Might that be the problem?
Also, should I just put it into the SD card slot in my laptop and format with the Windows Utility?

I don't think android data and obb files are responsible for this system uid problem.. Yes format it using windows utility.. If still facing prob try flashing ROM using any other recovery .. Yes before flashing ROM you know the needed steps so I won't tell it again.. Do the steps manually..

Sent from my Explorer A310e using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes