Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,401 Members 38,537 Now Online
XDA Developers Android and Mobile Development Forum

Rooting After Enabling Encryption

Tip us?
 
hattwj
Old
(Last edited by hattwj; 27th May 2014 at 11:01 PM.) Reason: forgot a flag for command added "-L data"
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: May 2014
Lightbulb Rooting After Enabling Encryption

I made the mistake of enabling encrption before rooting my new gs5. After rooting with chainfire and installing twrp my phone wouldnt boot. It would prompt for the decrypt key and then go to a black screen. I also tried to format the data partition inside of twrp, and although it said it worked I still got prompted to enter my decryption key at boot time. My guess is that TWRP was not actually formating the userdata partition.

When I eventually did was enter the following command into the terminal app inside of TWRP:

mke2fs -t ext4 -L data /dev/block/mmcblk0p26 11901935

*PLEASE NOTE: The 11901935 number is specific to the 16GB Sprint GS5. If you have a 32GB version you will want a different number.
*ADDITIONAL NOTE: Although the system runs I am still unable to encrypt the device.

Resources:

format howto:
http://www.bauer-power.net/2014/02/h...l#.U2Rv13VdW3I
http://forum.cyanogenmod.com/topic/8...splash-screen/


partition table for g900p:
http://forum.xda-developers.com/show....php?t=2725978

PS: Some posts on this subject suggest that the "11901935" value might need to be 16 fiddled with a little. If you are unable to encrypt your phone afterwards you might need to re-run the above command and subtract 16 or so from the above number.
 
hattwj
Old
(Last edited by hattwj; 27th May 2014 at 11:37 PM.) Reason: * new information
#2  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: May 2014
Angry Getting Encryption Back after enabling root

After I rooted I was completely unable to encrypt my phone. This is a pain, because I encryption is a big must. Whenever I would try to initiate the encryption process the android wireframe guy would appear for a second and then the screen would go black and unresponsive. Holding down the power button wouldn't do anything. The only way to reboot was for me to remove the battery and reboot. I found several posts about other phones where people were having the same issue, and I was eventually able to piece together a little how-to guide.


The trick for me was to combine several of these posts into something that works.

Instructions:


1.) Temporarily disable any SU software (Super SU etc)

2. ) Reboot phone into "Safe Mode":
Turn the phone off completely. Press and hold the power button until the screen comes on. As soon as the screen comes on release the power button and press/hold "volume down". Continue holding the volume down button until the phone is done booting. Once the boot process is complete there should be a little "SAFE MODE" logo in the lower left hand corner of the screen.

3.) Make sure device is plugged in to charger

4.) Encrypt Device:
Do NOT SELECT "Fast Encryption"

5.) Encrypt phone:
Once you start encrypting the phone it will immediately restart the phone and then the android wireframe logo should appear and a progress indicator will also be present.

PS, for some reason this makes SuperSU non functional.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes