Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,053 Members 46,447 Now Online
XDA Developers Android and Mobile Development Forum

Power Button Issues

Tip us?
 
kalans
Old
#1  
Member - OP
Thanks Meter 10
Posts: 42
Join Date: May 2014
Default Power Button Issues

Hello everyone, first time posting but I have been on the forums for some time now.

I have searched, but now my issue is more specific so I wanted to post about it.

I am running Cyanogen Mod 11 from around december time 2013.

Tonight out of the blue my device has been restarting and staying turned off, no indications previous and no new apps or recent changes etc. I looked up these issues and it points to the power button being stuck.

-I replaced the battery with a different one
-Booted into clockwork mod, trying to navigate to wipe cache etc and it would reboot the device before I made it there (did this many times)
-Trying to boot it normal and it wouldn't make it far without a reboot
-Took the device apart and cleaned up etc, took out the battery and held power and tried again (many times). No avail.
-Looked online for replacement buttons and saw what I would need to do, so I tried to unsolder the power button but to no avail.

This is where things looked up!

-Turned the device on and booted into CWM and did a backup successfully!
-Wiped devilk cache and normal cache (mind my spelling please), and rebooted.
-Made it to the starting up the apps (from the devilk wipe), and to the main screen to see "shutting down" as if the power button was still being pressed.
-Tried again many times, but still the same result.
-Did a key test in CWM and it doesn't show the power button being pressed, unless I press it (all other buttons worked fine).

So that is where I am at, I tried to do a reinstall of cyanogenmod with the windows installer but it wont detect it as before. Any suggestions? Thanks!
 
roirraW "edor" ehT
Old
#2  
roirraW "edor" ehT's Avatar
Senior Member
Thanks Meter 1310
Posts: 3,048
Join Date: May 2010
Location: Columbus, OH
What bootloader are you on? I would restore to stock for your current version of bootloader or newer by ODINing the stock tar. Then try the CM process again.

Sent from my Sprint Samsung Galaxy SIII on TouchWiz 4.4.2 with Wicked X v6.5, Ktoonsez' latest kernel and the latest Philz Touch Recovery.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes