Post Reply

Help with rooting

26th May 2014, 02:18 PM   |  #1  
OP Junior Member
Thanks Meter: 2
 
19 posts
Join Date:Joined: Jun 2009
Hey guys, so I'm trying to root my phone but I can't vet it going. I was able to unlock my boot loader using flashtool, so I know my computer has the proper drivers and what not.

The issue happens when I try to flash the kernel and recovery. I plug my phone, start the fastboot flash boot boot.img but then it gets stuck on "waiting for device."

Does any one have any tips or maybe has an idea on how to get this **** to work? THANKS!!

Sent from my D5503 using XDA Premium 4 mobile app
26th May 2014, 03:06 PM   |  #2  
zxz0O0's Avatar
Senior Member
Thanks Meter: 1,279
 
872 posts
Join Date:Joined: Apr 2011
Donate to Me
More
Are you actually booting your phone in fastboot mode? Do you have the fastboot drivers installed?

Open flashtool and then connect your phone in fastboot mode. Post screenshot here.
28th May 2014, 12:05 AM   |  #3  
OP Junior Member
Thanks Meter: 2
 
19 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by zxz0O0

Are you actually booting your phone in fastboot mode? Do you have the fastboot drivers installed?

Open flashtool and then connect your phone in fastboot mode. Post screenshot here.

Thanks for your reply dude. I have attached a screenshot of what shows. Its being detected correctly, but for some reason its not responding. Im assuming i have the fastboot drivers installed because i installed the drivers from the android sdk and i was about to unlock the bootloader using flashtool. thanks again for the help!
Attached Thumbnails
Click image for larger version

Name:	Untitled.jpg
Views:	67
Size:	254.3 KB
ID:	2766509  
28th May 2014, 08:00 AM   |  #4  
Senior Member
Flag Kolkata
Thanks Meter: 199
 
849 posts
Join Date:Joined: Oct 2009
More
Quote:
Originally Posted by moises319

Thanks for your reply dude. I have attached a screenshot of what shows. Its being detected correctly, but for some reason its not responding. Im assuming i have the fastboot drivers installed because i installed the drivers from the android sdk and i was about to unlock the bootloader using flashtool. thanks again for the help!

Did u put boot.img file in the same directory from where u launch faatboot command?

Sent from my Xperia Z1 Compact (D5503)
28th May 2014, 08:16 PM   |  #5  
OP Junior Member
Thanks Meter: 2
 
19 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by coolkoushik07

Did u put boot.img file in the same directory from where u launch faatboot command?

Sent from my Xperia Z1 Compact (D5503)

yeah, i had it in there. The great news is thati was bale to root it by adding "AdbWinUsbApi.dll" to the folder. Thanks again for the help!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes


Top Threads in Xperia Z1 Compact Q&A, Help & Troubleshooting by ThreadRank