Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[SOLVED] Rezound is on (i think), screen is off...

OP jasonmerc

28th May 2014, 10:41 PM   |  #1  
jasonmerc's Avatar
OP Senior Member
Flag Go ahead and try to find me...
Thanks Meter: 150
 
276 posts
Join Date:Joined: Dec 2012
More
When I hold the power button to turn the phone on, the screen remains blank. No HTC logo, not even on-but-only-showing-black. I mean blank as in the screen does not even turn on. The phone itself does seem to be on, because after a while of it being "on", when I touch the screen anywhere the phone gives off a slight vibration, however the screen still is blank.

My phone was working just fine yesterday, I have no clue what could have caused this. My phone is (or was) running Android 4.4.2 COMMOTIO, with CWM touch recovery by PhilZ if I remember correctly.
Last edited by jasonmerc; 29th May 2014 at 04:10 AM.
29th May 2014, 02:09 AM   |  #2  
pball52998's Avatar
Senior Member
Thanks Meter: 169
 
635 posts
Join Date:Joined: Jan 2014
More
Quote:
Originally Posted by jasonmerc

When I hold the power button to turn the phone on, the screen remains blank. No HTC logo, not even on-but-only-showing-black. I mean blank as in the screen does not even turn on. The phone itself does seem to be on, because after a while of it being "on", when I touch the screen anywhere the phone gives off a slight vibration, however the screen still is blank.

My phone was working just fine yesterday, I have no clue what could have caused this. My phone is (or was) running Android 4.4.2 COMMOTIO, with CWM touch recovery by PhilZ if I remember correctly.

Was the phone dead? Have you tried booting into Hboot/fastboot? When you plug it in do you get a orange light saying charging?
The Following User Says Thank You to pball52998 For This Useful Post: [ View ]
29th May 2014, 02:14 AM   |  #3  
jasonmerc's Avatar
OP Senior Member
Flag Go ahead and try to find me...
Thanks Meter: 150
 
276 posts
Join Date:Joined: Dec 2012
More
When I plug it into the outlet to charge, the orange light blinks on and off about 20 times then it just stops altogether. I tried hbooting it as well with the volume key + power but no luck.

EDIT: I just read that one should leave the phone plugged in for about 20 minutes before expecting it to take a charge. I will wait 20 minutes or so and report back what happens if anything.

EDIT: IT'S ALIIIIIVVVEEEEE!

Now I will tell how it happened, formatted as green text story

>be me
>be at night
>rezound plugged into wall for like 20 minutes
>no more orange light blinking
>notthiscrapagain.jpg
>unplug phone
>vibrating when I touch the screen
>but screen still off
>decide not to pull battery this time
>set it down for a minute
>screen isn't vibrating to touches anymore
>be like "battery must have ded"
>about to take off back shell
>vibration is felt
>turn phone around so I see screen
>mfw green htc boot logo shows
>mfw kitkat boots up
>thatwasclose.gif

(For those who don't know, mfw="my face when...")

So my guess is that the battery simply must have died while the phone was off. I am not sure about all of your rezounds, but yes, mine does discharge when turned off. Yes, even when it is on airplane mode.

Thanks to pball for attempting to diagnose the issue, by the way .

Sent from my SGH-I847 using XDA Free mobile app
Last edited by jasonmerc; 29th May 2014 at 03:22 AM.
Post Reply Subscribe to Thread

Tags
blank screen, rezound
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes