Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,192 Members 37,636 Now Online
XDA Developers Android and Mobile Development Forum

[Q] MMS not working with WiFi

Tip us?
 
conceptR
Old
(Last edited by conceptR; 28th May 2014 at 11:38 PM.) Reason: missing some info
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2010
Location: San Diego, CA
Default [Q] MMS not working with WiFi

Hello all,

I just recently got the Xperia Z2 and tried sending/receiving MMS picture messages with WiFi on at home and found that it will not go through until I turn it off. I'm currently in the States using the T-Mobile US network. As soon as I turn off WiFi, or if I'm out and about using my phone without WiFi on, I find that the MMS picture messages go through like normal, both receiving and sending. Is anyone having any issues with this that's on the US T-Mobile network, and are there any fixes to this? I haven't contacted T-Mobile yet but I've read a few other forums and it looks like other Android users are running into the same problem. I just haven't seen it brought up on the Xperia phones.

Here's some information on my phone:
- Stock D6503 (Taiwan version that came with the noise canceling headphones & magnetic charging dock)
- 4.4.2 Kit Kat
- Version 17.1.A.2.69
- Has not been rooted, bootloader has not been touched
- Using the stock Messaging app that was installed (Although I also tried downloading the SMS Messaging (AOSP) by Sylvain Galand in the Play Store and it didn't work either)
- MMS auto download & MMS when roaming are both on under the Messaging settings

APN settings were downloaded under the Wireless & networks > Internet Settings > T-Mobile US

Name: T-Mobile US
APN: fast.t-mobile.com
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: http://mms.msg.english.t-mobile.com/mms/wapenc
MMS Proxy: Not set
MMS Port: Not set
MCC: 310
MNC: 260
Authentication type: None
APN Type: default,supl,a-gps,mms
APN protocol: IPv6
APN roaming protocol: IPv4

Some other users are saying that their phones will send MMS messages if they enable WiFi calling, but I have not seen that feature included in our Xperia Z2's.
Source: http://support.t-mobile.com/thread/56934

I also read this: http://forum.xda-developers.com/show....php?t=2724390 and this http://support.t-mobile.com/docs/DOC-1979 with no solution so far.

I guess I could always just turn off the WiFi when sending or receiving MMS messages but I just wanted to ask the community if there was a fix for this.

I generally don't post questions in these forums as I try to dig around as much as possible before posting. Any help or tips would greatly be apprecaited!
 
se1000
Old
#2  
Senior Member
Thanks Meter 192
Posts: 468
Join Date: Feb 2011
Change your APN protocol from IPv6 to IPv4/IPv6
The Following 3 Users Say Thank You to se1000 For This Useful Post: [ Click to Expand ]
 
conceptR
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2010
Location: San Diego, CA
Quote:
Originally Posted by se1000 View Post
Change your APN protocol from IPv6 to IPv4/IPv6
Thank you so much! Who knew the solution was that simple! I just tried it and was able to send and receive MMS picture messages while connected to WiFi. Thanks again!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes